« Back to channel list

#RubyOnRails - 03 February 2019

« Back 1 day Forward 1 day »
[00:27:13] mostlybadfly: has joined #RubyOnRails
[00:28:31] tdy: has joined #RubyOnRails
[00:33:37] tdy: has joined #RubyOnRails
[01:09:09] orbyt_: has joined #RubyOnRails
[01:11:09] gambl0r3: has joined #RubyOnRails
[01:50:06] ellcs: has joined #RubyOnRails
[02:11:06] quazimodo: has joined #RubyOnRails
[02:26:25] funnel: has joined #RubyOnRails
[02:32:40] beholders_eye: has joined #RubyOnRails
[02:55:28] gambl0r3: has joined #RubyOnRails
[03:16:29] jottr: has joined #RubyOnRails
[03:35:12] Saukk: has joined #RubyOnRails
[03:57:18] orbyt_: has joined #RubyOnRails
[04:09:10] havenwood: has joined #RubyOnRails
[04:10:00] braincrash: has joined #RubyOnRails
[04:31:23] Tempesta: has joined #RubyOnRails
[04:34:28] cnsvc: has joined #RubyOnRails
[04:40:09] Xiti: has joined #RubyOnRails
[05:07:48] segy: has joined #RubyOnRails
[05:25:16] jottr: has joined #RubyOnRails
[05:30:01] segy: has joined #RubyOnRails
[05:40:58] orbyt_: has joined #RubyOnRails
[06:54:02] alfiemax: has joined #RubyOnRails
[07:32:19] jottr: has joined #RubyOnRails
[08:35:32] mikecmpbll: has joined #RubyOnRails
[08:42:30] beholders_eye: has joined #RubyOnRails
[08:51:33] reber: has joined #RubyOnRails
[09:27:51] catbusters: has joined #RubyOnRails
[09:30:40] jottr: has joined #RubyOnRails
[09:42:05] blackmesa: has joined #RubyOnRails
[09:42:38] alfiemax: has joined #RubyOnRails
[09:49:05] blackmesa: has joined #RubyOnRails
[10:06:32] quazimodo: has joined #RubyOnRails
[10:06:44] Jervis_: has joined #RubyOnRails
[10:16:59] ravenousmoose: has joined #RubyOnRails
[10:28:57] Fernando-Basso: has joined #RubyOnRails
[10:29:02] defsdoor: has joined #RubyOnRails
[10:29:31] GodFather: has joined #RubyOnRails
[10:40:51] kapil____: has joined #RubyOnRails
[10:56:51] timwis: Hi folks, I'm new to rails and trying to fix github security warnings like activestorage. But `bundle update activestorage` keeps it at the same version. I assume it's a dep of rails 5.2, so you'd think `bundle update rails` would do it, but it doesn't.. :/ any idea how?
[10:59:03] tbuehlmann: timwis: can you gist your Gemfile?
[11:01:57] ellcs: has joined #RubyOnRails
[11:03:56] timwis: tbuehlmann: https://gist.github.com/timwis/bc264df58aca7ee04ca0ff776c416f45
[11:05:23] tbuehlmann: okay, so '~> 5.2.0' will let you upgrade to 5.2.2, is that good enough?
[11:05:46] timwis: tbuehlmann: on which line?
[11:06:15] timwis: Yeah, it's already set to that though
[11:07:19] tbuehlmann: right, so you can upgrade to 5.2.2. I don't know githubs security policy on activestorage. what version do you need?
[11:08:33] timwis: tbuehlmann: how would i upgrade? `bin update rails` says the version didn't change
[11:10:52] tbuehlmann: `bundle update rails` should update unless another gem dependency prevents it
[11:11:03] timwis: sry i meant bundle
[11:11:11] tbuehlmann: you can try setting the version to '5.2.2' and try again
[11:11:30] timwis: Bundler attempted to update rails but its version stayed the same
[11:11:34] timwis: okay i'll manually set it
[11:13:07] tbuehlmann: what does `bin/rails -v` display? are you on 5.2.2 already?
[11:16:15] timwis: tbuehlmann: okay I think I got there... had to `bundle install` after manually updating the version. oddly one of my tests broke but i'll troubleshoot that.
[11:22:55] roshanavand: has joined #RubyOnRails
[11:35:21] roshanavand: has joined #RubyOnRails
[11:42:02] jottr: has joined #RubyOnRails
[11:43:11] conta: has joined #RubyOnRails
[11:50:17] lankanmon: has joined #RubyOnRails
[11:55:28] ariedler: has joined #RubyOnRails
[11:56:57] ariedler: has joined #RubyOnRails
[12:14:18] roshanavand: has joined #RubyOnRails
[12:23:37] lxsameer: has joined #RubyOnRails
[12:33:38] Puffball: has joined #RubyOnRails
[12:40:42] Guest16678: has joined #RubyOnRails
[12:51:15] jottr: has joined #RubyOnRails
[13:02:19] ravenousmoose: has joined #RubyOnRails
[13:02:44] Technodrome: has joined #RubyOnRails
[13:05:12] blackmesa: has joined #RubyOnRails
[13:24:35] uksio: has joined #RubyOnRails
[13:30:06] catbusters: has joined #RubyOnRails
[13:30:45] catbusters: Has anyone here used ActionCable?
[13:40:43] ravenousmoose: has joined #RubyOnRails
[13:49:51] swojtczak: has joined #RubyOnRails
[13:54:49] swojtczak: I bought a html template and placed it under public/assets, that works in dev but when trying to deploy it to production they seem to be removed, only assets from asset pipeline are present. moving everything into pipeline will be painful, is there any other option?
[14:28:17] mostlybadfly: has joined #RubyOnRails
[14:42:55] conta: has joined #RubyOnRails
[14:57:48] ariedler: has joined #RubyOnRails
[15:07:01] beingjohnm: has joined #RubyOnRails
[16:01:11] blackmesa: has joined #RubyOnRails
[16:02:33] roshanavand: has joined #RubyOnRails
[16:15:58] blackmesa1: has joined #RubyOnRails
[16:16:53] Dbugger: has joined #RubyOnRails
[16:18:24] DTZUZO: has joined #RubyOnRails
[17:10:12] blackmesa1: has joined #RubyOnRails
[17:21:46] alfiemax: has joined #RubyOnRails
[17:29:59] dionysus70: has joined #RubyOnRails
[17:31:04] tdy: has joined #RubyOnRails
[17:38:43] za1b1tsu: has joined #RubyOnRails
[17:54:19] tdy: has joined #RubyOnRails
[18:21:59] orbyt_: has joined #RubyOnRails
[18:22:29] octos: has joined #RubyOnRails
[18:27:27] Andr3as: hi all.. i am having an API and it works as expected.. however, a third party wants to request a json reply of my "identity".. that req in the browser works fine, though wen the 3rd party app asks for it, i get an ActionController::UnknownFormat error
[18:27:52] Andr3as: as the req format seems to be html (request.formats: ["text/html"])
[18:28:14] Andr3as: is there a way to tell rails to serve json no matter what? kinda like ignore that the req asks for html?
[18:29:43] Andr3as: fwiw, that's my controlelr which serves the json https://gist.github.com/awunder/b7521d4db9df5cacd5bba349bced83f5
[18:30:33] Andr3as: its a bit of a test right now, so dont focus on the missing auth and what not..
[18:30:59] octos: You can set default on your routes.rb `resources :users, defaults: { format: 'json' }`
[18:31:17] Andr3as: thing is, it already defaults on json
[18:31:25] Andr3as: lemme post the error
[18:31:45] Andr3as: trade added
[18:33:06] Andr3as: so, that 3rd party seems to specifically requests html (for whatever reason)
[18:33:26] octos: they probably are requesting on accept header
[18:34:17] Andr3as: so you still think that "format: :json" might fix that?
[18:34:31] octos: you can try to puts params[:format] at your controller and see
[18:35:48] Andr3as: will try.. its a bit of an open heart surgery on the staging env.. have that 3rd party app nowhere else..
[18:35:53] Andr3as: thank god for capistrano
[18:36:01] gambl0r3: has joined #RubyOnRails
[18:40:30] Andr3as: i dont get that far.. throws the error right away.. probably even before it executes the method
[18:46:06] octos: I'm not 100% sure, but at your error trace the rails prints "request.formats: ["text/html"] \n request.variant: []"
[18:46:23] za1b1tsu: has joined #RubyOnRails
[18:46:44] octos: The 3rd party client is requesting and "text/html" and you fixed at your controller to only respond json at `repond_to :json`
[18:47:13] octos: But I'm not 100% sure of this
[18:47:30] Andr3as: yes, as this is an api.. i just try to disguise html as json now.. lets see what happens
[18:48:57] octos: as workaround you can change request.format to :json on before_action callback https://stackoverflow.com/questions/4800219/how-to-set-the-default-format-for-a-route-in-rails
[18:49:15] octos: or you remove the default from routes, and the respond_to of your controller
[18:49:35] octos: But it's only my guess
[19:07:02] Andr3as: i put the default format into the routes.. the error is gone but it doesnt serve what its supposed to do
[19:07:06] Andr3as: https://gist.github.com/awunder/3387050b3c2005da863e95bc337a2aa9
[19:07:26] Andr3as: first req is made be the 3rd party app.. it serves :no_content
[19:07:49] Andr3as: 2nd req is made by me in the browser, it serves what i expect it to
[19:11:09] Andr3as: sh*t .. i gotta go..
[19:11:40] conta: has joined #RubyOnRails
[19:18:42] cnsvc: has joined #RubyOnRails
[19:40:33] ellcs: has joined #RubyOnRails
[19:47:29] za1b1tsu: has joined #RubyOnRails
[20:01:55] duderonomy: has joined #RubyOnRails
[20:25:21] hahuang6-: has joined #RubyOnRails
[20:35:53] carbone5: has joined #RubyOnRails
[20:41:20] krawchyk: has joined #RubyOnRails
[20:41:22] carbone5: has joined #RubyOnRails
[21:02:01] beholders_eye: has joined #RubyOnRails
[21:04:27] beholders_eye: has joined #RubyOnRails
[21:24:27] roshanavand: has joined #RubyOnRails
[21:26:30] cnsvc: has joined #RubyOnRails
[21:33:25] Technodrome: has joined #RubyOnRails
[21:36:31] armyriad: has joined #RubyOnRails
[21:38:10] aatayyab_: has joined #RubyOnRails
[21:38:25] aatayyab_: my name is amir
[21:38:40] aatayyab_: i am new to ruby on rails
[21:39:11] aatayyab_: i just used http://railsinstaller.org/en to install it
[21:39:32] aatayyab_: do i need to install anything else to start practising on my windows computer?
[21:41:47] aatayyab_: i am new on this chat room too... i hope i am asking right question in a right way
[22:08:19] lexileo: has joined #RubyOnRails
[22:08:21] gambl0r3: has joined #RubyOnRails
[22:54:54] carbone5: has joined #RubyOnRails
[23:04:36] carbone5: has joined #RubyOnRails
[23:21:44] carbone5: has joined #RubyOnRails
[23:21:51] quazimodo: has joined #RubyOnRails
[23:31:34] carbone5: has joined #RubyOnRails
[23:49:22] roshanavand: has joined #RubyOnRails