Akuma

Activity Graph

Page 1 of 2 | Next »

2018-01-06

[17:04:21] Akuma: has joined #ruby
[17:06:10] Akuma: Hello, I have a question I can't seem to resolve with google: I have a variadic arg function ( def f(*args)), args being a series of strings. When I do `args.each do |i| { str += '' }` I receive a message that i is nul
[17:06:47] Akuma: any idea what I should be doing to access the string within the args I've passed?
[17:07:36] Akuma: I didn't paste the functional code, I can do a pastebin
[17:08:31] Akuma: https://0bin.net/paste/VfFpxhrD++pbB23v#ISu2MwG-hc484BC78LtRzr+Pr4K2PHUSVqfffld2SLb
[17:09:01] Akuma: missing the last "end" on the paste
[17:09:27] Akuma: nevermind, I figured out the issue, I hat to do `q.to_s`
[17:10:46] Akuma: havenwood: Thank you!
[17:10:52] Akuma: I didn't think of that
[20:58:39] Akuma: has left #ruby: ("Leaving")

2017-04-17

[11:14:38] Akuma: has joined #ruby
[11:29:12] Akuma: Quit: So long sukkas!
[11:34:09] Akuma: has joined #ruby
[11:45:09] Akuma: Quit: So long sukkas!

2016-07-25

[00:05:02] Akuma: has joined #RubyOnRails
[00:05:31] Akuma: has left #RubyOnRails: ()
[00:05:49] Akuma: has left #RubyOnRails: ()
[00:05:49] Akuma: has joined #RubyOnRails

2016-07-24

[20:36:03] Akuma: Ping timeout: 240 seconds

2016-07-20

[13:04:15] Akuma: Read error: Connection reset by peer
[13:50:43] Akuma: has joined #RubyOnRails
[13:50:43] Akuma: has joined #ruby

2016-07-19

[14:54:48] Akuma: has joined #RubyOnRails
[14:54:48] Akuma: has joined #ruby

2016-07-07

[00:29:02] Akuma: Quit: So long sukkas!

2016-07-06

[12:01:38] Akuma: has joined #RubyOnRails
[12:01:38] Akuma: has joined #ruby

2016-07-01

[01:49:13] Akuma: Quit: So long sukkas!

2016-06-29

[01:22:50] Akuma: Quit: So long sukkas!
[19:32:40] Akuma: has joined #RubyOnRails
[19:32:40] Akuma: has joined #ruby

2016-06-28

[13:07:23] Akuma: has joined #RubyOnRails
[13:07:23] Akuma: has joined #ruby

2016-06-22

[05:38:25] Akuma: Ping timeout: 252 seconds

2016-06-21

[07:16:17] Akuma: Ping timeout: 258 seconds
[15:12:29] Akuma: has joined #RubyOnRails
[15:12:29] Akuma: has joined #ruby
[15:39:30] Akuma: Quit: So long sukkas!
[19:25:39] Akuma: has joined #RubyOnRails
[19:25:39] Akuma: has joined #ruby

2016-06-20

[12:24:46] Akuma: has joined #RubyOnRails
[12:24:46] Akuma: has joined #ruby

2016-06-18

[04:59:03] Akuma: has joined #ruby
[04:59:04] Akuma: has joined #RubyOnRails
[05:28:14] Akuma: Quit: So long sukkas!

2016-06-17

[22:34:25] Akuma: Quit: So long sukkas!

2016-06-15

[17:15:41] Akuma: Ping timeout: 240 seconds
[17:33:04] Akuma: has joined #RubyOnRails
[17:33:04] Akuma: has joined #ruby

2016-06-14

[12:17:38] Akuma: has joined #RubyOnRails
[12:17:38] Akuma: has joined #ruby

2016-06-13

[14:09:04] Akuma: has joined #ruby
[14:09:05] Akuma: has joined #RubyOnRails
[20:28:35] Akuma: Quit: So long sukkas!

2016-06-12

[23:42:56] Akuma: Quit: So long sukkas!

2016-06-11

[22:17:01] Akuma: has joined #RubyOnRails
[22:17:01] Akuma: has joined #ruby

2016-06-10

[20:26:48] Akuma: has joined #ruby
[20:26:49] Akuma: Client Quit
[20:26:49] Akuma: has joined #RubyOnRails

2016-05-18

[19:44:02] Akuma: has joined #RubyOnRails
[19:44:02] Akuma: has joined #ruby
[19:45:27] Akuma: Hello, I'm encountering an issue with delayed jobs. My delayed jobs table is empty, but I am seeing a lot of updates on the logs
[19:46:02] Akuma: the application is currently being slowed down by many of these updates which are preventing normal operation of the rails app
[19:46:28] Akuma: I have tried clearing the jobs with rake jobs:clear and restarting the instance without success, these updates keep on happening
[19:47:29] Akuma: Here is an excerpt of the log: https://gist.github.com/autronix/4f2b11ac3c07d1ff193bf86ed11fe9c3
[19:49:33] Akuma: yes, we had this issue in the past, normal operation stops as soon as the delayed jobs end
[19:49:52] Akuma: by delayed jobs, I mean the types of operations shown in the log
[20:16:02] Akuma: Quit: So long sukkas!

2016-05-17

[02:07:37] Akuma: has joined #RubyOnRails
[02:07:37] Akuma: has joined #ruby
[02:10:04] Akuma: Hello, I'm experincing a bit of an issue. I have some code that functions properly in my development environment, bu when deployed, even though the migration is done, I get the following error: https://gist.github.com/autronix/1b1f106d5d0c2621d587e9586c83a12e
[02:10:17] Akuma: this is the relevant code in my model file: https://gist.github.com/autronix/adfb783a0c97bf21c49ab64ce910eae9
[02:59:45] Akuma: Quit: So long sukkas!

2016-04-13

[12:06:54] Akuma: Ping timeout: 248 seconds

2016-04-12

[16:47:42] Akuma: has joined #RubyOnRails
[16:47:42] Akuma: has joined #ruby
[16:53:16] Akuma: Hello, I have a rails application running on heroku, roughly 2800 registered users, I am currently experiencing a lot of delayed jobs which are causing request timeouts for the web workers
[16:53:45] Akuma: The delayed jobs are ActiveRecord jobs
[16:55:42] Akuma: smathy: I am not entirely sure, I am basing myself on the log information: "Delayed::Backend::ActiveRecord::Job Load (7.0ms) "
[16:57:44] Akuma: because I am flooded by them
[16:57:56] Akuma: I have 12 workrers going through them
[16:58:02] Akuma: and they keep on appearing
[16:58:31] Akuma: smathy: adding workers actually alliviated the issue in terms of the request timeouts
[16:58:43] Akuma: I was using 2 workers and the application was unusabe
[16:58:47] Akuma: *unusable
[17:00:41] Akuma: Here's a video of the loging process through papertrail: http://screencast-o-matic.com/watch/cDflDK1B0g
[17:00:51] Akuma: showing what I mean
[17:02:01] Akuma: fair enough... ok, in that case, how are delayed jobs typically started?
[17:02:22] Akuma: or what would normally send a request for it?
[17:02:52] Akuma: We've picked up the application... Agreed, somebody messed up big time
[17:03:16] Akuma: the whole design is a disaster; that being aside, I have to find a solution for the active users
[17:04:30] Akuma: is there any way to find out the source of the delayed job?
[17:04:38] Akuma: as in who is requesting it?
[17:06:03] Akuma: Thank you all, I'll further investigate this
[17:06:07] Akuma: I appreciate the help

2016-03-01

[01:23:19] Akuma: Quit: So long sukkas!

2016-02-29

[15:26:35] Akuma: has joined #RubyOnRails
[15:26:35] Akuma: has joined #ruby

2015-10-09

[02:28:22] Akuma: Quit: So long sukkas!

2015-10-08

[19:13:08] Akuma: has joined #RubyOnRails
[19:13:08] Akuma: has joined #ruby

2015-08-25

[13:42:11] Akuma: has joined #RubyOnRails
[13:42:11] Akuma: has joined #ruby
[13:46:06] Akuma: Client Quit

2015-05-25

[14:23:43] Akuma: has joined #RubyOnRails
[14:23:43] Akuma: has joined #ruby
[15:01:12] Akuma: Quit: So long sukkas!
[15:17:41] Akuma: has joined #RubyOnRails
[15:17:41] Akuma: has joined #ruby
[17:23:15] Akuma: Quit: So long sukkas!

2015-02-25

[17:39:29] Akuma: hello, I'm having some issues with css files: I want a css file to be applied only to a single layout; I removed the require tree from application.css, but it is still being loaded in the main application
[17:40:03] Akuma: rushed: but I do
[17:40:33] Akuma: smathy: I will try that
[17:41:32] Akuma: rushed: too late for that, it was not planned in my design, I have to work around it
[17:45:18] Akuma: I have done assets precompile for production, but I am running in the development env right now
[17:50:11] Akuma: smathy: it seems bootstrap is screwing up my things... I added it only to the css that I want on the other layout, but it seems to be loaded anyways in the normal application, which is messing with my styling
[17:53:22] Akuma: I have added the css file to config/initializers/assets.rb in order to be able to load it on the layout, and that css file contains the bootstrap-sass-rails @import statements, but for some reason they are crossing over into the main application even though it shouldn't be loaded
[17:53:53] Akuma: rushed: I did that, unfortunately the problem remains after restarting the server

2014-12-13

[05:00:06] Akuma: hello, I'm having a bit of an issue. One of the SaaS applications that connect to my rails app provides me with a response to a GET page that contains a parameter called "action", however, when I puts the contents of params, action is shown as the rendering controller method
[05:00:34] Akuma: I'm not quite sure on how to solve this issue
[05:03:14] Akuma: the format of the request is http://myhost/my_controller/my_method?action=saas_action&etc
[05:06:23] Akuma: micaeked: I'll give that a try, thanks
[05:08:11] Akuma: micaeked: that worked great, thanks a lot

2014-12-05

[00:22:29] Akuma: hello, is there any way to detect in a before_filter the hostname being requested by the client (ie. if host= www.ecample.com do this)?
[00:24:09] Akuma: workmad3: I'll give that a try, thanks

2014-11-29

[20:31:44] Akuma: hello, how can I get the current host within a mailer? (request.host is not working)
[20:33:44] Akuma: so, just pass it as a parameter
[20:34:10] Akuma: I'll give that a try. Thanks for the advise
[20:35:01] Akuma: is there any way to pass a parameter to the before_filter?
[20:37:48] Akuma: I'll read through it, thanks a lot

2014-11-26

[16:50:41] Akuma: hello, what is the site for pasting code?
[16:57:40] Akuma: pastebin seems to be frowned upon
[17:00:32] Akuma: I have the following issue with active_admin and I cannot seem to be able to solve it (the gem is properly installed and the files it's looking for are in one of the directories listed in the paste): http://pastie.org/9745126
[17:00:42] Akuma: I'm not quite sure how to solve this issue
[17:00:51] Akuma: everything was working before I bundle updated
[17:01:53] Akuma: I did that
[17:01:56] Akuma: didn't work
[17:02:40] Akuma: same errors appears when I try to do rake assets:precompile
[17:09:30] Akuma: pacMakaveli: it does not
[17:09:58] Akuma: I'm currently in development though
[17:10:26] Akuma: what I am concerned about is the fact that it doesn't see the gem files even though they are present
[17:10:31] Akuma: I'll give that a try
[17:11:55] Akuma: the issue persists
[17:12:08] Akuma: on both the page and rack assets:precompile
[17:14:46] Akuma: rails 4.1.0, active_admin 1.0.0 and sass 3.4.9
[17:15:28] Akuma: sass-rails 5.0.0-beta1
[17:23:39] Akuma: pacMakaveli: yea, I understand
[17:26:38] Akuma: pacMakaveli: switching to 4.0.3 seems to have done the trick. I appreciate the help
[17:26:48] Akuma: I guess the issue was with sass-rails
[17:27:28] Akuma: thanks a lot

2014-11-14

[02:20:01] Akuma: hello, what is the best way to do an SQL union?
[02:20:38] Akuma: I mean with activerecord

2014-11-11

[03:03:31] Akuma: hello, is it possible to specify a migration t.belongs_to :table as something other than table_id?
[03:05:08] Akuma: how can I achieve that?
[03:09:49] Akuma: I want to create a table that references to itself through a "t.belongs :table" but I don't want the result to be table id; for example "t.belongs_to :mytable, :as => :my_special_field"
[03:11:56] Akuma: here is my migration: http://pastebin.com/ExXnaiCP
[03:12:49] Akuma: http://pastie.org/9710847
[03:15:07] Akuma: because I need some plans to refer to parent plans
[03:17:53] Akuma: I'll try to work another way, thanks for the help
[03:45:23] Akuma: cleopatras: thanks, I'll take a look at it

2014-09-21

[19:37:54] Akuma: Hello, I'm having an issue where my images and fonts are precompiled but the app, once deployed is still calling the files by their original name
[19:38:04] Akuma: I haven't been able to figure out why
[19:38:54] Akuma: these image and font calls are done in the css files (the files are caled through image-url() and font-url() )
[19:39:10] Akuma: any help would be greatly appreciated

2014-03-15

[02:22:02] Akuma: elaptics`away: I wanted to thank you for the help, I managed to get it working thanks to your advise
[02:22:16] Akuma: uberjar: same to you
[17:04:19] Akuma: hello, in capistrano 3, how can I call a task from another task in the same namespace?
[19:40:53] Akuma: Hello, how can I access a hash within an array; doing print my_array[0][:hash_key] gives me an error
[19:42:25] Akuma: the error is the following: `block in process': undefined method `[]' for nil:NilClass (NoMethodError)
[19:43:00] Akuma: I'm an idiot, I found my problem
[19:43:24] Akuma: I was doing an each on the array and was still trying to acces the hash from the array value....
[19:43:30] Akuma: thanks anyways for the help :)

2014-03-14

[17:41:46] Akuma: Hello, I'm trying to run a deployment with capistrano however at some point I get "rake aborted! Specified 'postgresql' for database adapter, but the gem is not loaded. Add gem 'pg' to your Gemfile." - My gemfile currently includes 'pg'; I have also tried to run the task manually doing bundle exec rake assets:precompile. I cannot seem to figure out what I am missing.
[17:41:55] Akuma: Any help would be greatly appreciated
[17:48:57] Akuma: where can I find the deployment log?
[17:50:49] Akuma: amortimer: https://gist.github.com/autronix/9553015
[17:52:50] Akuma: but I commited/pushed my changes to the repo
[17:56:13] Akuma: amortimer: any clues as to where I should try looking for a problem?
[17:59:29] Akuma: I only have one version of ruby with RVM
[18:03:07] Akuma: amortimer: not that I know of, I'm running it pretty default
[18:04:28] Akuma: amortimer: yeah, that has been bothering me as well, I figured it was just a warning message
[22:20:38] Akuma: Hello, I'm having some issues with javascript and css assets in production mode with precompiled assets. My image calls work fine but I can't get the css and js to be found
[23:24:31] Akuma: Hello, I'm having a hard time figuring out why my deployed application is not able to access js and css even though it manages to access image assets. Here is a paste of all the files I think are relevant to this issue. Any help would be greatly appreciated as I am not quite sure what else to do.
[23:24:34] Akuma: https://gist.github.com/autronix/45776d1231a410340cf3
[23:26:23] Akuma: do that on the local or remote host?
[23:26:39] Akuma: I use <%= tags
[23:26:59] Akuma: I'm using capistrano to deploy
[23:27:17] Akuma: the latest
[23:27:22] Akuma: running rails 4
[23:27:49] Akuma: I will give that a try
[23:28:27] Akuma: elaptics: let me do a paste
[23:30:08] Akuma: https://gist.github.com/autronix/736f8c34810e4dad084a
[23:33:20] Akuma: let me check
[23:33:57] Akuma: I see it; I'll give that a try
[23:36:23] Akuma: I will read it, should help a lot
[23:37:00] Akuma: do you add the scss to the line or do you specify the css version?

2014-03-11

[02:02:12] Akuma: Hello can anyone advise hosting that supports RRuby2/Rails 4 along with php (apache). I am having a hard time finding a suitable candidate
[02:08:25] Akuma: centrx: I'm not sure, I can't find any reliable information
[02:10:48] Akuma: yes, I have some old websites still running on it
[02:11:01] Akuma: that I need to keep, I have made the switch to rails
[02:11:08] Akuma: but still got to run those
[09:39:28] Akuma: Hello can anyone advise hosting that supports RRuby2/Rails 4 along with php (apache). I am having a hard time finding a suitable candidate
[09:40:49] Akuma: mikecmpbll: web hosting
[09:41:28] Akuma: most of what I can find have cpanel which only supports Ruby 1.8.3 + Ruby 2
[09:42:51] Akuma: mikecmpbll: yea, I was thinking about that but the cost is a bit on the high side
[09:44:00] Akuma: I keep on stumbling on digital ocean, but can't seem to find much information or reviews on it
[09:48:32] Akuma: elaptics: that it ridiculously cheap
[09:49:31] Akuma: elaptics: not sure how they would sustain on only one-time-costs if everyone goes with that option and doesn't choose to pay the monthly subscription
[09:50:57] Akuma: that might be why
[10:00:57] Akuma: go with ubuntu or centos6.5?
[10:02:41] Akuma: yea, I use both at home
[10:03:38] Akuma: but centos comes with cpanel, so that would make my life a bit easier for managing some of my other sites
[10:03:58] Akuma: although I don't know if that will have an impact on the version of Ruby I can install

2014-03-10

[14:40:37] Akuma: Hello, I have done this in my routes: get '/:locale' => 'welcome#index' but when I try to do localhost:3000/fr/ it renders the english version (I have the localization working with a def set_locale method in application_controller using a get parameter localhost:3000/?lg=fr)
[14:40:56] Akuma: what am I missing?
[14:43:31] Akuma: universa1: not sure what you mean; here's the code: http://pastebin.com/e3QRsQgN
[14:47:09] Akuma: universa1: so I should add || params[:locale]
[14:49:38] Akuma: universa1: adding params[:locale] || worked. I was asking for advise and opinion. either way your comments helped. I appreciate it

2014-03-09

[16:20:41] Akuma: hello, what is the best way to translate strings within javascript assets (I've tried gem i18n-js but I cannot get it to work)?
[16:39:20] Akuma: polysics: glad to know I'm not the only one...
[16:40:07] Akuma: the main issue that I'm having with i18n-js is that the i18n.js script is not being installed when I do rake i18n:js:setup
[16:42:13] Akuma: polysics: Angualr?
[16:56:51] Akuma: polysics: I just got it working: I used I18n-js-pika and then manually copied the I18n/* and I18n.js from the gem dir to the /public/javascripts
[16:57:59] Akuma: for some reason the ruby app was not using the js from the gem
[16:59:07] Akuma: polysics: https://github.com/PikachuEXE/i18n-js for the gem
[20:21:21] Akuma: Hello, is it possible to run rake db:seed but only from one seed file (for example I have multiple files in db/seeds/)

2014-03-08

[19:06:11] Akuma: Anyways, here's what I want to do and have not been able to achieve: I want to get the data fom a model that belongs to another model based on a filter; I can achieve this by doing @listing = SomeModel.find_by_field1('whatever').belonging_model.all to get all records, however I want to be able to filter the second model based on a filed and haven't been able to get results doing that.
[19:07:31] Akuma: In other words I want to select all data that matches the second filter after it's been run through the first filter (fox example all boxes that belong to section 1 that match "cube" in the box model field)