CGibsonmm

Activity Graph

Page 1 of 2 | Next »

2019-01-07

[18:48:39] CGibsonmm: has joined #RubyOnRails
[18:55:12] CGibsonmm: Ping timeout: 252 seconds
[19:01:58] CGibsonmm: has joined #RubyOnRails
[19:02:02] CGibsonmm: on of @user but passes terms_of_service: true
[19:02:02] CGibsonmm: I am trying to test a User in a RSpec.feature test, I want to update my users to have a column the accepts a boolean, say terms_of_service: true, In my model I have a validation on create that force the user to validates :terms_of_service, acceptance: true I need a way do something like this in my feature test that allows something like @user = create(:user, terms_of_service: false) rspec/rails allows the creati
[19:03:06] CGibsonmm: I need to be able to test against a user in the db that is already there prior to the new column, at this time all users have terms_of_service
[19:03:21] CGibsonmm: : false, as the default.
[19:10:39] CGibsonmm: Remote host closed the connection
[19:14:05] CGibsonmm: has joined #RubyOnRails

2018-12-18

[17:46:21] CGibsonmm: has joined #RubyOnRails
[17:49:27] CGibsonmm: I am running into issues with rails 5.2 ActiveStorage some images after they are uploaded they are being displayed sideways, from what I see active storage is not saving anything other than a height x width of images and has no orientation data saved, I am also having issues trying to attach minimagic to any part of the blob that is saved with rails
[17:55:13] CGibsonmm: This seems to be the only documentation on exif and activestorage https://api.rubyonrails.org/classes/ActiveStorage/Analyzer/ImageAnalyzer.html
[18:26:08] CGibsonmm: Remote host closed the connection
[18:47:38] CGibsonmm: has joined #RubyOnRails
[18:52:12] CGibsonmm: Ping timeout: 250 seconds
[23:36:04] CGibsonmm: has joined #RubyOnRails
[23:40:25] CGibsonmm: Ping timeout: 250 seconds

2018-12-17

[14:54:10] CGibsonmm: has joined #RubyOnRails
[14:54:52] CGibsonmm: Anyone know why calling Time.now in a private controller method in rails returns a time 18 years ago?
[14:56:37] CGibsonmm: How would you change that? or what would cause that?
[14:56:56] CGibsonmm: All of my other time methods are correct
[14:59:00] CGibsonmm: the default times like created_at: from rails is correct...
[15:00:30] CGibsonmm: tryed that also, even DateTime.current
[15:01:05] CGibsonmm: {id: 1, published_on: "2000-01-01 14:57:59", created_at: "2018-12-17 14:57:56", updated_at: "2018-12-17 14:57:59" }
[15:03:30] CGibsonmm: haha! Thanks, have it set to time.

2018-12-15

[19:01:30] CGibsonmm: has joined #RubyOnRails
[19:02:13] CGibsonmm: Using a jbuilder I need to set my key as a symbol such as key: but i keep getting "key": returned
[19:03:09] CGibsonmm: i tryed json.set! :key, but and still getting a "string":
[19:45:10] CGibsonmm: Remote host closed the connection
[19:45:45] CGibsonmm: has joined #RubyOnRails
[19:55:37] CGibsonmm: Remote host closed the connection
[19:55:51] CGibsonmm: has joined #RubyOnRails
[20:53:51] CGibsonmm: Remote host closed the connection
[20:54:26] CGibsonmm: has joined #RubyOnRails
[20:55:02] CGibsonmm: Read error: Connection reset by peer

2018-12-14

[00:02:36] CGibsonmm: has joined #RubyOnRails
[01:46:36] CGibsonmm: Remote host closed the connection
[01:47:10] CGibsonmm: has joined #RubyOnRails
[02:04:21] CGibsonmm: Remote host closed the connection
[02:04:36] CGibsonmm: has joined #RubyOnRails
[02:36:40] CGibsonmm: Ping timeout: 264 seconds

2018-12-13

[15:13:14] CGibsonmm: has joined #RubyOnRails
[15:15:38] CGibsonmm: Good morning, I am looking into ways to get around an issue I am having where, bootstrap sticky-top nav is interfering with passing anchors via link_to (some_link, anchor: some_post ) The link is working but the anchor is only showing at the top of the page and the sticky nav is hiding int
[16:15:28] CGibsonmm: Ping timeout: 245 seconds
[17:08:51] CGibsonmm: has joined #RubyOnRails
[17:18:39] CGibsonmm: Read error: Connection reset by peer
[18:26:22] CGibsonmm: has joined #RubyOnRails
[18:28:31] CGibsonmm: While running a js function, I am calling $(document).on('turbolinks:load', function(){. console.log( $('myid')) }) only returns jquery.fn.init and will not find the element on the page. Is there a workaround for this?
[18:52:33] CGibsonmm: Remote host closed the connection
[19:04:44] CGibsonmm: has joined #RubyOnRails
[19:08:54] CGibsonmm: Ping timeout: 246 seconds
[19:09:22] CGibsonmm: has joined #RubyOnRails
[19:25:50] CGibsonmm: Ping timeout: 272 seconds
[22:22:33] CGibsonmm: has joined #RubyOnRails
[22:29:55] CGibsonmm: Ping timeout: 246 seconds
[22:48:17] CGibsonmm: has joined #RubyOnRails
[23:01:48] CGibsonmm: Ping timeout: 272 seconds

2018-11-22

[02:51:10] CGibsonmm: has joined #RubyOnRails
[02:56:49] CGibsonmm: Is there a way to write a simple query that would do something, like ordering a post via the latest comments in a post has_many comments assosiation
[04:27:43] CGibsonmm: Remote host closed the connection
[05:05:34] CGibsonmm: has joined #RubyOnRails
[12:55:50] CGibsonmm: Ping timeout: 276 seconds
[15:51:21] CGibsonmm: has joined #RubyOnRails
[16:09:26] CGibsonmm: Remote host closed the connection

2018-11-17

[00:14:21] CGibsonmm: has joined #RubyOnRails
[00:17:10] CGibsonmm: hello, I am looking to dynamically load in a modal through a js jbuilder that renders a partial, I have the jbuilder working and rendering other things correctly, but when I try to also load in modal in the partial and I click the link to display the modal, I get the fade class, but no data from the modal is displayed.
[00:17:46] CGibsonmm: when I inspect the html the modal shows up but its like the bootstrap js is not calling it
[00:19:56] CGibsonmm: Is it because the bootstrap js looks at the dom only on the original page load? and if so is there any patch to override that?
[00:52:52] CGibsonmm: Remote host closed the connection
[02:11:42] CGibsonmm: has joined #RubyOnRails
[02:12:23] CGibsonmm: Client Quit

2018-11-13

[00:01:17] CGibsonmm: So would it be safe to get rid of the rest of the through: associations? and then go back and re-read there use?
[00:04:34] CGibsonmm: Radar: Thank you, it is working as expected now!
[00:08:04] CGibsonmm: Radar: That's fine it works now! Thank you Again

2018-11-12

[13:11:26] CGibsonmm: has joined #RubyOnRails
[13:14:56] CGibsonmm: Question about the differences between pg on production and sqlite on local/dev, Its seems that local rails is building record associations but my production app and database all my through associations return empty arrays
[13:20:15] CGibsonmm: Remote host closed the connection
[21:10:05] CGibsonmm: has joined #RubyOnRails
[21:19:13] CGibsonmm: Question about the differences between pg on production and sqlite on local/dev, Its seems that local rails is building record associations but my production app and database all my through associations return empty arrays, What am I missing?
[21:22:01] CGibsonmm: say I search user.forum_posts which forum_post belongs_to user and belongs_to forum_thread and user has_many on both post and thread
[21:22:20] CGibsonmm: It will return an empty array
[21:27:05] CGibsonmm: LOL, so basically my data got mad at its mom, packed it's bags and ran away?
[21:27:40] CGibsonmm: 8:00 pm bed time ruins everything...
[21:28:20] CGibsonmm: yes for certin
[21:33:52] CGibsonmm: https://gist.github.com/cgibsonmm/449d20c2cf1525fadcda937b39800068
[21:34:18] CGibsonmm: I have "For Certain" forum_posts on my production server
[21:35:16] CGibsonmm: It's seem to be working intermittently say I search a diffrent user It will return the correct array,
[21:36:44] CGibsonmm: The correct array.
[21:39:00] CGibsonmm: yeah updated the gist https://gist.github.com/cgibsonmm/449d20c2cf1525fadcda937b39800068
[21:42:31] CGibsonmm: so full is chain categories > topic > thread > post
[21:44:35] CGibsonmm: hhhhm, when I originally built the association I never put a user_id column in the categories du to the fact that only admin would create them any way
[21:45:10] CGibsonmm: I can go back add the column and add the id to all
[21:45:35] CGibsonmm: haha! thanks
[21:46:55] CGibsonmm: So aside from the fact that I am going to just add a column and add my user id to all, will that have any other sideeffects?
[21:50:23] CGibsonmm: wait I just checked my schema and yes categories does have a user_id
[21:51:02] CGibsonmm: I will add my schema to the gist
[21:56:17] CGibsonmm: okay, sounds good
[23:32:27] CGibsonmm: https://gist.github.com/cgibsonmm/449d20c2cf1525fadcda937b39800068/edit
[23:32:36] CGibsonmm: ... minus the edit
[23:45:21] CGibsonmm: Radar updated it
[23:48:10] CGibsonmm: Sorry that was just a typo in the gist
[23:50:48] CGibsonmm: Radar: in my categories create method I am calling @category = current_user.forum_categories.builds(create_params), I don't think that has anything to do with the Query but just letting you know how that is done
[23:54:01] CGibsonmm: Okay trying the change, to see
[23:55:25] CGibsonmm: that may make the diff I ran the user.forum_posts.to_sql and it returned "SELECT \"forum_posts\".* FROM \"forum_posts\" WHERE \"forum_posts\".\"user_id\" = 1"
[23:57:23] CGibsonmm: Okay I am trying in production now

2018-11-10

[03:22:04] CGibsonmm: Remote host closed the connection
[03:22:20] CGibsonmm: has joined #RubyOnRails

2018-11-09

[05:17:55] CGibsonmm: has joined #RubyOnRails
[05:19:46] CGibsonmm: looking to access the after_create method on devise new user where would I place this? I have seen docs on after_create_sign_up_path but not where to add a method to the devise controller
[06:43:28] CGibsonmm: Yeah, Finally got it working Thank you
[06:55:10] CGibsonmm: Remote host closed the connection
[06:55:47] CGibsonmm: has joined #RubyOnRails
[13:50:26] CGibsonmm: Ping timeout: 276 seconds
[18:32:51] CGibsonmm: has joined #RubyOnRails
[18:37:02] CGibsonmm: Ping timeout: 250 seconds
[21:59:07] CGibsonmm: has joined #RubyOnRails
[23:33:16] CGibsonmm: Remote host closed the connection
[23:33:53] CGibsonmm: has joined #RubyOnRails

2018-11-06

[16:14:30] CGibsonmm: has joined #RubyOnRails
[16:20:36] CGibsonmm: when calling a remote: true from a form where is it looking for the file, say i have a file structure of threads/posts/likes/_create.js. if the create link in in the posts show the create is proscessed correct but the js response is not found. how can i point the remote true to point to the likes/_create
[16:22:38] CGibsonmm: No template found for ForumThreads::ForumPosts::LikesController#create, rendering head :no_content
[16:23:07] CGibsonmm: this is the error i get from the server
[16:24:02] CGibsonmm: I have a respond to format.js
[16:24:38] CGibsonmm: format.html { redirect_to @forum_thread}
[16:24:38] CGibsonmm: respond_to do |format|
[16:27:54] CGibsonmm: i want it to add a like, then remove the like link from the page and replace it with delete like, i have all the js written its just not finding that js file witch is in forum_posts/links
[16:36:54] CGibsonmm: and its not finding it
[16:37:11] CGibsonmm: its in post/like/create.js.erb
[16:39:00] CGibsonmm: yeah it is but on the create i am getting No template found for ForumThreads::ForumPosts::LikesController#create, rendering head :no_content
[16:39:28] CGibsonmm: yes it is likes/create that was just a typo here
[16:45:13] CGibsonmm: no routing error
[16:46:32] CGibsonmm: scratch that no i can not
[16:48:43] CGibsonmm: resource :likes, module: :forum_posts
[16:48:43] CGibsonmm: resources :forum_posts, module: :forum_threads do
[16:52:40] CGibsonmm: forum_posts/:forum_post_id/like/new(.:format) forum_threads/forum_posts/likes#new
[16:52:48] CGibsonmm: all is returned like normal
[16:53:41] CGibsonmm: POST /forum_posts/:forum_post_id/like(.:format) forum_threads/forum_posts/likes#create
[16:56:40] CGibsonmm: yeah i dont know why its not locating thenfile
[17:05:37] CGibsonmm: haha! throw computer out window!
[17:05:54] CGibsonmm: nah i am gonna take it to stack overflow
[17:07:47] CGibsonmm: thank you, that just solved where its looking for the file
[17:40:10] CGibsonmm: Remote host closed the connection
[19:54:02] CGibsonmm: has joined #RubyOnRails
[19:55:06] CGibsonmm: calling this js from my create $("#forum_posts_<%= @forum_post.id %>").html("<%=escape_javascript(render( partial: 'forum_posts/likes')) %>"); is working but is not changing the view
[19:55:57] CGibsonmm: #ids match it just wont update i am running rails 5 and have jquery3 and rails ujs
[19:56:02] CGibsonmm: Remote host closed the connection

2018-10-30

[00:31:45] CGibsonmm: Remote host closed the connection

2018-10-29

[20:06:13] CGibsonmm: has joined #RubyOnRails
[20:06:29] CGibsonmm: How do you stop aws links from expiring?
[20:06:49] CGibsonmm: I am trying to get photo upload but my links always expire

2018-10-25

[16:26:07] CGibsonmm: has joined #RubyOnRails
[16:32:02] CGibsonmm: ead and keep that subject id to submit to thread model?
[16:32:02] CGibsonmm: I have a question about building a forum, i have a subjects model, a thread model, and a posts model. I want to keep my subjects and thread separate from each other/ resources nested, but I want to only create a new thread after routing through a certain subject, the thread model belongs_to a subject and a subject has many threads, but i do not want their resources nested, how can i link through subjects-> to thr
[16:39:19] CGibsonmm: basically i still need a full index of every thread, but the need a subject

2018-04-05

[18:44:17] CGibsonmm: has joined #RubyOnRails
[18:49:04] CGibsonmm: goodday I Have a user 1:1 user_profile User is handled by devise I am trying to create the User_profile, with default params along with the create of the USER, I tried a before_create in the user model setting @profile = create_user_profile!(default_parmas) I am getting a stack lvl too deep error when I run RSPEC
[18:51:47] CGibsonmm: When I run through rails s and try to create my user It attempts to beginnig the transaction and calls CACHE User Exists (0.0ms) SELECT 1 AS one FROM "users" WHERE "users"."email" = ? LIMIT ? [["email", "test@gmail.com"], ["LIMIT", 1]] about 100 times and then fails, Any help with why this is happining would be awesome
[19:16:06] CGibsonmm: Remote host closed the connection
[21:31:06] CGibsonmm: has joined #RubyOnRails
[22:02:30] CGibsonmm: Remote host closed the connection

2018-03-22

[12:41:46] CGibsonmm: has joined #RubyOnRails
[12:44:28] CGibsonmm: I have a question about factory_bot, I have a 1:1 association for my user and user_profile model, and on user sign up it also call create on the user_profile, how can i reflect that in my factory generation, i keep ending up with a empty user_profile
[15:00:13] CGibsonmm: Remote host closed the connection

2018-03-20

[13:59:43] CGibsonmm: has joined #RubyOnRails
[14:00:28] CGibsonmm: msg NickServ REGISTER cg359997 cgibsonmm@gmail.com
[14:04:26] CGibsonmm: okay, anyway I have a question about routing through the a controller, I have an image model that on the create action it renders a crop method to crop a photo, I am looking to do the same thing on the edit method also. so it would route edit crop then update
[14:43:55] CGibsonmm: Remote host closed the connection
[16:33:03] CGibsonmm: has joined #RubyOnRails
[16:33:14] CGibsonmm: having issue with my cropper.js file called form a gem being rendered too soon and default styles and fucntion not working unless reloading the page. Is there an easy way to hold up the render?
[16:33:50] CGibsonmm: will check it out
[16:50:48] CGibsonmm: has left #RubyOnRails: ()

2017-05-26

[04:22:29] CGibsonmm: has joined #RubyOnRails
[04:22:40] CGibsonmm: I need to set AWS region for US East (Ohio), is this us_east_2?
[05:10:58] CGibsonmm: Remote host closed the connection
[05:55:43] CGibsonmm: has joined #ruby
[06:00:07] CGibsonmm: Ping timeout: 260 seconds
[07:44:36] CGibsonmm: has joined #ruby
[07:49:04] CGibsonmm: Ping timeout: 240 seconds
[08:38:45] CGibsonmm: has joined #ruby
[08:42:51] CGibsonmm: Ping timeout: 240 seconds
[09:32:56] CGibsonmm: has joined #ruby
[09:37:29] CGibsonmm: Ping timeout: 255 seconds
[10:26:46] CGibsonmm: has joined #ruby
[10:30:57] CGibsonmm: Ping timeout: 240 seconds
[11:20:51] CGibsonmm: has joined #ruby
[11:26:01] CGibsonmm: Ping timeout: 255 seconds
[12:15:21] CGibsonmm: has joined #ruby
[12:23:55] CGibsonmm: Ping timeout: 246 seconds
[13:39:01] CGibsonmm: has joined #ruby

2017-04-13

[23:07:55] CGibsonmm: has joined #RubyOnRails
[23:07:59] CGibsonmm: undefined local variable or method `post' for #<RSpec::ExampleGroups::CanViewIndividulPosts:0x007ffb137468a8
[23:08:14] CGibsonmm: I have a question about a feature test. line in question= "expect(page.current_path).to eq(post_path(post))" rspec is returning undefined local variable or method `post' for #<RSpec::ExampleGroups::CanViewIndividulPosts:0x007ffb137468a8
[23:10:56] CGibsonmm: I have a question about a feature test. line in question= "expect(page.current_path).to eq(post_path(post))" rspec is returning undefined local variable or method `post' for #<RSpec::ExampleGroups::CanViewIndividulPosts:0x007ffb137468a8
[23:13:43] CGibsonmm: I have it defined in my controller, i am going from index to show page, and both are defined in the controller
[23:14:51] CGibsonmm: When i run the server everything works lol
[23:16:56] CGibsonmm: got it thanks you!
[23:19:16] CGibsonmm: I see I originally had new_post = create(:post), and was just calling (post) ThX

2017-04-11

[22:53:32] CGibsonmm: has joined #RubyOnRails
[22:53:32] CGibsonmm: has joined #ruby
[23:09:17] CGibsonmm: Remote host closed the connection
[23:10:45] CGibsonmm: has joined #RubyOnRails
[23:10:45] CGibsonmm: has joined #ruby
[23:16:37] CGibsonmm: Quit: Leaving

2017-04-10

[17:47:45] CGibsonmm: has joined #RubyOnRails
[17:47:45] CGibsonmm: has joined #ruby

2017-04-07

[12:39:09] CGibsonmm: has joined #RubyOnRails
[12:39:09] CGibsonmm: has joined #ruby
[12:40:15] CGibsonmm: is anyone familiar with semantic-ui? and how I can change variables in my rails app?
[14:39:44] CGibsonmm: help translating this line to haml <nav class="top-bar" data-topbar role="navigation">
[15:16:37] CGibsonmm: Ping timeout: 246 seconds
[16:28:57] CGibsonmm: has joined #ruby
[16:28:58] CGibsonmm: has joined #RubyOnRails
[17:37:38] CGibsonmm: While adding user_name to rails 5 app, and following devise git hub to permit additional params, i entered code directly. but and still reciving unpermited_param error before the db rollback
[18:24:26] CGibsonmm: has joined #RubyOnRails
[18:24:26] CGibsonmm: has joined #ruby
[18:27:22] CGibsonmm: Ping timeout: 246 seconds
[18:51:30] CGibsonmm: has joined #RubyOnRails
[18:51:30] CGibsonmm: has joined #ruby
[18:51:31] CGibsonmm: Ping timeout: 246 seconds
[19:32:18] CGibsonmm: has joined #RubyOnRails
[19:32:18] CGibsonmm: has joined #ruby
[19:34:55] CGibsonmm: Ping timeout: 246 seconds
[19:40:36] CGibsonmm: has joined #RubyOnRails
[19:40:36] CGibsonmm: has joined #ruby
[19:42:37] CGibsonmm: Ping timeout: 246 seconds
[19:53:07] CGibsonmm: Ping timeout: 246 seconds

2017-03-31

[23:07:05] CGibsonmm: Remote host closed the connection
[23:52:44] CGibsonmm: has joined #RubyOnRails
[23:52:44] CGibsonmm: has joined #ruby
[23:58:56] CGibsonmm: Remote host closed the connection