_bogus_

Activity Graph

Page 1 of 2 | Next »

2016-07-25

[18:52:41] _bogus_: has joined #RubyOnRails
[19:02:17] _bogus_: Quit: Page closed

2016-03-21

[01:36:55] _bogus_: how can I create a virtual column for 'confirmation' in User (using devise) that's gettable and settable like a column? Like, @user.confirm = true, or @user.confirm = false, or @user.confirm can return true/false depending on confirmation status
[01:38:53] _bogus_: timdotrb, not yet, ill give it a look, thanks
[02:08:13] _bogus_: hey, I'm trying to use attr_accessor to create a virtual method for devise confirmation in my model, but it doesn't gets updated via activeadmin (which I presume uses update_attributes).. only using @user.confirmation = true in console... https://gist.github.com/andreycwb/86a86906cdf8ab4046dd what am I doing wrong?
[02:10:05] _bogus_: sevenseacat, i thought of that too but the param is declared on permit_params
[02:11:04] _bogus_: checkout gist again pls
[02:12:31] _bogus_: no error, it just doesnt gets set
[02:12:49] _bogus_: but i dont think it is a problem with active admin. probably im doing something wrong in my code
[02:14:16] _bogus_: just added a log to gist
[02:15:22] _bogus_: humm.. you're right..
[02:15:35] _bogus_: forgot to check on this..
[02:23:01] _bogus_: Radar, that was it , its working now , thanks !
[14:25:36] _bogus_: Remote host closed the connection

2016-03-20

[01:44:05] _bogus_: has joined #RubyOnRails
[01:44:06] _bogus_: has joined #RubyOnRails
[01:44:06] _bogus_: Changing host
[04:56:59] _bogus_: hi there. im using activeadmin which uses formstastic, and ckeditor (using galetahub/ckeditor gem)... is there an easy way to load the ckeditor only if a select has a certain value ?
[04:59:47] _bogus_: Quit: Saindo
[05:01:53] _bogus_: has joined #RubyOnRails
[05:02:10] _bogus_: has joined #RubyOnRails
[05:02:10] _bogus_: Changing host
[06:54:14] _bogus_: Read error: No route to host
[07:32:36] _bogus_: has joined #RubyOnRails
[07:32:36] _bogus_: Changing host
[07:32:36] _bogus_: has joined #RubyOnRails
[12:27:43] _bogus_: hi, I have this line of code for setting up classes for some rows depending on the value of record.tipo ... its working fine, but i would like how to define more classes for more tipo values: index(:row_class => -> record { 'classe' if record.tipo == "legenda" } ) do .. can I have a help please?
[12:28:23] _bogus_: like, 'classe1' for tipo == 'tipo1', 'classe2' for 'tipo2', and so on
[12:33:30] _bogus_: sorry I'll try to be clearer , im using activeadmin and I want to stylize the show table, but Im not very sure about how those "->" lines works... but I found this one on stackoverflow and its working, but what I would like to do is something like this: ['class1', 'class2', 'class3'] if record.tipo == ['tipo1', 'tipo2', 'tipo3']... not sure if you get the idea.. this tipo is a enum field in the model so its also an integer, maybe it can b
[12:34:59] _bogus_: i think i should use %w{ } and somehow check the tipo integer value... but those single-line statements really confuses me.

2016-03-19

[06:59:14] _bogus_: has joined #RubyOnRails
[10:34:45] _bogus_: Read error: No route to host

2016-03-17

[00:00:30] _bogus_: ok thanks anyway
[06:13:49] _bogus_: Am I doing something wrong? why the before_save method isnt being called? https://gist.github.com/andreycwb/42fb1a41e5efb288976c I tried before_validation also to see if it was not saving because of validation but it didnt work either... This model belongs to model Mapa, and thats what Im saving but I guess this shouldnt prevent the before_save method of being called..
[06:45:44] _bogus_: sevenseacat, on before_save
[06:50:18] _bogus_: alfie_max15, actually im updating a Mapa record, but I expect it to work on create/update. I expect the check_blank method to be called before saving the model to db
[06:59:28] _bogus_: alfie_max15, i thought of this too, but even if I change before_save to before_validate it doesnt be called
[07:15:20] _bogus_: alfie_max15, oh but I actually want to set persona_avatar nil only if all those fields are blank, anyway, they're allowed to be blank
[07:20:59] _bogus_: arup_r, no error actually, only its not calling my check_blank method
[07:22:25] _bogus_: arup_r, neither byebug pausing the server
[07:22:36] _bogus_: arup_r, not yet, ill try that
[07:29:40] _bogus_: yes, with raise 1.inspect i got a Runtime Error: 1 , both when trying to create Persona and when trying to create new Mapa with Persona
[07:29:52] _bogus_: also tried the original code and it works when creating Persona
[07:29:53] _bogus_: via console
[07:30:30] _bogus_: also notice that both objects had empty fields (they're allowed to be blank on both methods)
[07:30:37] _bogus_: both models*
[07:32:02] _bogus_: updating existing record also gave me runtime error 1
[07:33:10] _bogus_: right .. then it must be some problem somewhere... strange, the form was working fine before...
[07:48:45] _bogus_: very strange.. when I save the model with something inside the fields I get the raise 1.inspection , but when I save with all fields blank I get nothing..
[07:49:18] _bogus_: even if its an existing model and im updating its fields... the fields are saved tho.
[07:54:12] _bogus_: but I guess ill get to sleep, my head is exploding , cant see one more line of code
[07:54:22] _bogus_: thanks for helping!
[18:00:19] _bogus_: Ping timeout: 268 seconds
[18:01:02] _bogus_: has joined #RubyOnRails
[18:01:02] _bogus_: Changing host
[18:01:02] _bogus_: has joined #RubyOnRails
[18:16:39] _bogus_: Quit: Saindo
[19:37:15] _bogus_: has joined #RubyOnRails
[22:35:09] _bogus_: Remote host closed the connection

2016-03-16

[04:26:40] _bogus_: hey, i created a method to do custom search on database, and from this query I want to render a json object, but I only want in this json object 2 parameters: the id, and the url(:small) for the paperclip field, how can I do this?
[05:10:09] _bogus_: https://gist.github.com/andreycwb/4969f70358b9a6e8cc9a please, when I create those radiobuttons, the second one comes checked by default. is there any way to change this? and better, is there a way to have both come unchecked by default?
[07:17:30] _bogus_: hey there.. i need to submit my form via ajax... its a long form and it has image uploaded included. i didnt tried yet but i saw some solutions using serialize(), but Im fearing it'll not be possible to upload the image using this method
[07:17:40] _bogus_: any ideas on how to do this ?
[07:20:23] _bogus_: hmmm... but didnt it uploads only the image? I need to submit the whole form...
[07:33:24] _bogus_: isnt there another way? my form is already done and working, its a long form
[08:25:30] _bogus_: Remote host closed the connection
[20:29:38] _bogus_: has joined #RubyOnRails
[20:29:38] _bogus_: Changing host
[20:29:38] _bogus_: has joined #RubyOnRails
[20:31:30] _bogus_: please, can I have a help on this?? https://gist.github.com/andreycwb/ec22848f718c25798708 (running capistrano), after I added activeadmin gem. Apparently, when running bundle install on server it cant install the bundle from the github. The point is, its necessary to use the github to avoid a loop in geminstall (its on the docs)
[20:42:28] _bogus_: apparently its not an activeadmin error, but a github error when trying to connnect
[22:06:31] _bogus_: how can I check if my model (devise) is confirmable ?
[22:09:55] _bogus_: if its confirmable
[22:10:22] _bogus_: if I have devise :confirmable on it
[22:11:26] _bogus_: I need to check it on my controller
[22:11:51] _bogus_: Im trying to use Usuario.class.devise_modules.confirmable? but this gets me an error (undefined method 'devise_modules' for Class:Class)
[22:12:01] _bogus_: no but I need to know where to redirect the user to
[22:15:40] _bogus_: nvm just solved it
[23:24:18] _bogus_: please, Im trying to retrieve the errors for my form via json, they're being returned, but this is the response: https://gist.github.com/andreycwb/a622aac4f0520c23b86c , I actually have 4 objects in my form (Mapa has_many Personas), two of them have invalid fields, but I'm getting only one error, and getting no object index, how can I retrieve this? (the html response is working fine)
[23:37:54] _bogus_: please how can I create a custom json output for form errors? containing field's name, object index for nested fields, and full message
[23:41:56] _bogus_: Radar, thanks, ill try that
[23:58:27] _bogus_: Radar, i can iterate through errors tho if I have many nested forms, I cant get the specific object's field with error :/

2016-03-15

[03:39:23] _bogus_: has joined #RubyOnRails
[03:39:24] _bogus_: has joined #RubyOnRails
[03:39:24] _bogus_: Changing host
[03:39:51] _bogus_: hi there.. i cant attach a image file to my devise confirmation email, what am i doing wrong? https://gist.github.com/andreycwb/7e95f4993099aaf11460
[04:24:43] _bogus_: hi there.. i cant attach a image file to my devise confirmation email, what am i doing wrong? https://gist.github.com/andreycwb/7e95f4993099aaf11460
[04:30:18] _bogus_: arup_r, i tried this too without success :/
[04:32:17] _bogus_: arup_r, yes, commenting that line with image_tag , everything works just fine
[04:33:54] _bogus_: yes, undefined .url for nil:NilClass
[04:35:02] _bogus_: oh I saw this on one of the pages searching for a solution. didnt help anyway
[04:37:47] _bogus_: same error tho :/
[04:42:05] _bogus_: sorry, pry ? just the word pry ?
[04:43:50] _bogus_: byebug is included in my gemfile
[04:55:28] _bogus_: arup_r, i tried to put byebug but nothing happened.. so i tried to set @a = 'aaaa' and use it on the view, strangely it doesnt prints anything in the view, Im thinking the method is not overriding or being called... despite Im using instance var @usuario inside my views and getting all the data w/out problem
[05:04:14] _bogus_: arup_r, yess, i just found out
[05:04:23] _bogus_: needed to set it on config/initialisers/devise.rb
[05:04:33] _bogus_: its working now !
[05:05:45] _bogus_: arup_r, i cant believe i spend all my time without knowing about this haha
[05:05:51] _bogus_: saves a lot of time
[05:08:46] _bogus_: arup_r, sure, thanks for the tip
[18:00:11] _bogus_: Ping timeout: 244 seconds
[18:00:51] _bogus_: has joined #RubyOnRails
[20:27:50] _bogus_: this... any ideas?
[20:27:50] _bogus_: hi there.. im trying to create a custom page for when the user signs up, telling him to check his confirmation email (im using devise). couldnt find a similar page in devise views so Im creating a new one under usuarios#confirmacao, but i would like to render the confirmation resend form from devise, which requires a 'resource' variable, which I suppose is the Usuario model (record) for the user signing up, tho im not very sure how to set
[21:49:46] _bogus_: this... any ideas?
[21:49:46] _bogus_: hi there.. im trying to create a custom page for when the user signs up, telling him to check his confirmation email (im using devise). couldnt find a similar page in devise views so Im creating a new one under usuarios#confirmacao, but i would like to render the confirmation resend form from devise, which requires a 'resource' variable, which I suppose is the Usuario model (record) for the user signing up, tho im not very sure how to set
[22:42:41] _bogus_: please, im using this: <%= p.collection_select(:persona_avatar_id, PersonaAvatar.all, :id, :avatar) %> where :avatar is a paperclip field . for now :avatar is returning to me the url of the image, is there a way to get the url for the :small image ?

2016-03-14

[02:07:03] _bogus_: has joined #RubyOnRails
[02:57:17] _bogus_: ve, but its not working...
[02:57:17] _bogus_: hi there.. can I have some help with this? https://gist.github.com/andreycwb/313060d2902da436db7e , there's two contexts to save the model, the normal (:create or :update) which allows_blank fields, and the :generate context, in which blank fields are not allowed.. this is working fine for the create method, but not for the update. I created a new function in the model just like update_attributes , but passing the validation context on sa
[04:18:44] _bogus_: Read error: No route to host
[18:02:26] _bogus_: has joined #RubyOnRails
[18:07:22] _bogus_: e app). Now I cant find ways to skip this using this gem for mailjet... sorry, im totally unfamiliar with ssl certificates, isnt there a simple way to generate this?
[18:07:22] _bogus_: hi there, can I have some help on certificates please? Im trying for days to configure the ActionMailer on production server without success.. already tried the server's sendmail, gmail, and now mailjet (using a gem). Im getting this error: OpenSSL::SSL::SSLError (hostname "in-v3.mailjet.com" does not match the server certificate). With gmail I got this too, but I skipped openssl verify (then I couldnt access the smtp for being an insecur
[18:14:55] _bogus_: i dont have any of them i guess... where should I get those certificates?
[18:16:15] _bogus_: I was looking about creating self-signed certificates but I guess this isnt the case..
[18:18:03] _bogus_: right... i have this file
[18:22:30] _bogus_: the file is there , there's plenty of keys on it.. but im not sure if there's keys for gmail or mailjet (I suppose I need a separate key for each of them)
[18:29:07] _bogus_: epochwolf, sorry, I tried to set the var system wide (creating a file /etc/profile.d/ssl_cert.sh with SSL_CERT_FILE=/path/file.crt), but I'm getting the same error still
[18:29:41] _bogus_: is that the case there's no entry for the hosts im trying to access? Or did I do something wrong
[18:30:49] _bogus_: i did restart my bash session, and passenger also..
[18:32:12] _bogus_: strangely, when i do 'env' my var doesnt appears in the list
[18:37:15] _bogus_: epochwolf, yes, i cant restart the server.. I did added export to that file, the var is showing up now with 'env | grep SSL' but only for the normal user and deploy user, not for root
[18:37:52] _bogus_: epochwolf, to check this var only...
[18:38:04] _bogus_: not sure but I thought it should be visible for root too..
[18:39:11] _bogus_: yeah, just to check this var.. but what you said makes sense..
[18:42:21] _bogus_: not sure what to do now...
[19:31:54] _bogus_: please im trying to override this method https://github.com/mailjet/mailjet-gem/blob/333577a4f950690a069e46453359d6d9e07002fd/lib/mailjet/connection.rb what am I doing wrong? https://gist.github.com/andreycwb/19ddbe580fe47814b10f
[19:49:31] _bogus_: is that possible that Rails is not reading system's certificates?
[19:53:14] _bogus_: cnk im not sure but im going nuts trying to config this... im trying to configure the smtp for production server and whenever I try something i get those ssl error (certification for host unknown). I tried to disable openssl but cant connect to gmail. Tried mailjet using a gem but cant disable openssl verify
[19:54:29] _bogus_: I already tried to set environment variable $SSL_CERT_FILE , tried to override gem's method not to verify ssl, tried to copy the ca-bundle.crt to lib/ and create an initializer to load it (as ive found on google)
[19:56:18] _bogus_: I believe its a commercial cert.. its a hosting server, there's a yum package ca-certificates (if im not wrong) which is installed too
[19:58:13] _bogus_: despite my rails errors, I can connect to gmail smtp using openssl s_client .. (just cant authenticate because of gmail's policy about insecure apps)
[19:59:04] _bogus_: cnk, sorry im not sure about this intermediate certificate... im using apache, there's other sites hosted on this machine (not sure if they use smtp but they're working fine as long as I know)
[20:01:43] _bogus_: im not very sure... they're wordpress projects, the machine has a cpanel (but im not using it). also, doing a find i see those wp projects has a separate certificate under project/wp-includes/certificates/ca-bundle.crt
[20:03:52] _bogus_: cnk, if I can access the smtp server using openssl s_client... does that means the certificates are loaded for openssl ?
[20:05:11] _bogus_: the server has also a sendmail which is working in command line, but when I try to use it inside rails I get a 'temporary server error'..
[20:08:08] _bogus_: cnk, thanks anyway
[20:08:15] _bogus_: fox_mulder_cp, thanks ill google that
[20:50:08] _bogus_: Read error: No route to host
[20:53:52] _bogus_: has joined #RubyOnRails
[23:00:11] _bogus_: Remote host closed the connection

2016-03-13

[15:58:03] _bogus_: Remote host closed the connection

2016-03-12

[15:54:44] _bogus_: has joined #RubyOnRails
[17:46:28] _bogus_: hi there... im getting this error https://gist.github.com/andreycwb/007a27def1280cfd09c0 when trying to restart passenger... apparently it occurs only when I try this command inside my rails project's folder (it works on ~/ or other directory), not sure why, but I'm using capistrano to deploy and capistrano tries to restart passenger and gets me the same error
[17:46:54] _bogus_: (actually capistrano is trying another passenger command and return this same error)
[17:49:13] _bogus_: arup_r, https://gist.github.com/andreycwb/007a27def1280cfd09c0 i added the capistrano log part where I get this error
[17:50:29] _bogus_: apparently when I run any passenger command from the project's folder I get those errors (it doesnt happens when I execute it from a folder without a rails app). I've googled on it and found something wrong with the rubygems and a workaround but im not really sure about how to use this workaround as it's about editing some rubygems source files, nor if its a good thing to do
[18:18:53] _bogus_: alter the rubygems source, im not sure if this is a good thing... im thinking of overriding capistrano tasks, it would be a neater solution probably, but I tried to override :restart task and still get the error, I think there's more tasks dealing with passenger, im not very sure how to do this right
[18:18:53] _bogus_: smathy, im not sure either... could it be because i've installed passenger using "gem install passenger" (as the problem seems to occur only when passenger is run in a project's folder)? actually i tried the other way but i would need to recompile the kernel or disable SELINUX, what a couldn't do... there's a possible explanation and temporary fix https://github.com/rubygems/rubygems/issues/1420#issuecomment-169178431 , but its needed to
[18:24:58] _bogus_: smathy, how can I override the passenger tasks ? I tried to create a task in deploy.rb , under namespace :deploy, and also under namespace :passenger , but neither has worked when using 'cap production deploy', it insists to run the default tasks..
[18:25:33] _bogus_: (just added the code snippet in the gist)
[18:35:22] _bogus_: just got it working with "set passenger_restart_with_touch, true" !! thanks
[19:15:56] _bogus_: im getting this error when accessing my app: Incomplete response received from application . What can it be? Already tried to set the secret key base...
[19:16:22] _bogus_: and RailsEnv production in httpd.conf
[19:49:29] _bogus_: im getting this error when accessing my app: Incomplete response received from application . What can it be? Already tried to set the secret key base in secrets.yml, putting the inside the file... also tried to set RailsEnv production in httpd.conf , no success...
[19:50:25] _bogus_: well it was one of the solutions ive found on google, but didnt work tho..
[19:50:53] _bogus_: no clues on the logs too
[19:51:10] _bogus_: Im using apache + passenger
[19:52:24] _bogus_: well I always used apache.. this is not on my pc tho, its on a shared hosting server
[19:52:44] _bogus_: cant change it :/ ... but it was working fine
[19:53:12] _bogus_: with a deploy I did manually , but it probably wasnt working on production mode... I did it very badly just to show a preview for the client..
[19:53:16] _bogus_: now I'm using capistrano
[19:53:39] _bogus_: it seems to be working well but Im getting this damn error... and all I find on google is about this secret_key_base being unset
[20:02:18] _bogus_: this rake secret should be executed on the server or on my local machine ?
[20:06:33] _bogus_: well , despite my secret_key_base is set in secrets.yml thats the error im getting on log: https://gist.github.com/andreycwb/22adb8cf908a84a7d935 ... what can I do to solve this ?
[20:09:18] _bogus_: oh forget it , just got it working

2016-03-10

[14:54:58] _bogus_: hey, do I need to require 'capistrano/rvm' and 'capistrano/passenger' if im on my local machine? (server has both but my local machine has only rvm)
[15:41:20] _bogus_: can I have some help on this? https://gist.github.com/anonymous/125e9008c16ec83b826e
[16:20:58] _bogus_: does anybody knows how can I use bitbucket with capistrano ?
[19:11:00] _bogus_: when running rails c i get this : /usr/local/rvm/gems/ruby-2.3.0/gems/spring-1.6.3/lib/spring/server.rb:42:in `initialize': too long unix socket path (112bytes given but 108bytes max) (ArgumentError) .. any ideas on how to fix this?
[19:35:05] _bogus_: sorry guys, yeah the path is a little long, but isnt there a way to get through this ? also, the mysql.sock is located at /var/lib/mysql/mysql.conf
[19:37:34] _bogus_: i found that
[19:37:38] _bogus_: but I cant change my path
[19:37:45] _bogus_: so I dont know what to do exactly
[19:38:30] _bogus_: at least if i did it right...
[19:40:08] _bogus_: sorry, actually i didnt tried to set $SPRING_TMP_PATH because i dont know what to set it to
[19:40:26] _bogus_: im not in my dev machine
[19:40:30] _bogus_: im in the production server
[19:42:27] _bogus_: yes, i thought that for a moment (im not really sure what spring is for, sorry)
[19:42:39] _bogus_: but i get this error running rails c production
[19:44:05] _bogus_: ok... just removed it and its working now, thanks.. just for the case, I was getting this error when running rails c console , despite it was under group :development on my Gemfile, was I doing anything wrong ?
[19:45:22] _bogus_: yes, actually my deploy is a mess.... Ive spent two days configuring server, and trying to deploy using capistrano
[19:45:45] _bogus_: couldnt use capistrano after all, then I cloned the git repo inside the production server's folder
[19:45:51] _bogus_: and its "running" with a lot of error
[19:46:17] _bogus_: i like it too but the client insisted to deploy it to his server.
[19:46:22] _bogus_: which had no support for rails.
[19:46:27] _bogus_: really a mess.
[19:48:20] _bogus_: i wish... but its very complicated... anyway, i believe that if I can create a temporary user using rails c he'll stop bothering me for the next days so I have time to configure capistrano right
[19:48:36] _bogus_: then he can test the app
[19:49:09] _bogus_: tubbo, no problem
[20:17:51] _bogus_: Read error: No route to host

2016-03-09

[14:08:20] _bogus_: is it too bad to call a search from a view, like this <%= FormConteudo.find_by_string_id('desc_empresa') %> ?
[14:09:01] _bogus_: sorry, missed the field, <%= FormConteudo.find_by_string_id('desc_empresa').ajuda %>
[14:10:04] _bogus_: its working but im not sure if this is a good practice.. but I have this page and I'll need to get various rows from this FormConteudo model searching by it's string_id
[14:14:37] _bogus_: maybe a helper ?
[14:19:24] _bogus_: codabrink, typically... but I need to check on many records of that model... actually I want the admin to edit many portions of some views, so I created a model where he can edit those portions, and each portion is a record identified by string_id, so inside the view I'll have many of those portions specified by this string_id
[14:22:10] _bogus_: im thinking of a helper maybe, to be more tidy
[15:03:52] _bogus_: https://gist.github.com/anonymous/ede779e61bd77a75822a please, i have set some default values for options (:tag => :p and :class => ''), but when I call this helper passing tag or class param alone, the other param became unavailable.. for ex, fc_legenda('something', {tag: :h1}) , the options inside the helper becomes {tag: h1}, with no :class ... what can I do here?
[15:18:19] _bogus_: https://gist.github.com/anonymous/ede779e61bd77a75822a please, i have set some default values for options (:tag => :p and :class => ''), but when I call this helper passing tag or class param alone, the other param became unavailable.. for ex, fc_legenda('something', {tag: :h1}) , the options inside the helper becomes {tag: h1}, with no :class ... what can I do here?
[16:06:28] _bogus_: https://gist.github.com/anonymous/ede779e61bd77a75822a please, i have set some default values for options (:tag => :p and :class => ''), but when I call this helper passing tag or class param alone, the other param became unavailable.. for ex, fc_legenda('something', {tag: :h1}) , the options inside the helper becomes {tag: h1}, with no :class ... what can I do here?
[16:10:47] _bogus_: universa1, thats the intention but i would like to overwrite only the params Im passing
[16:12:26] _bogus_: yes.. i understand you.. but what I would like is something like this: def method(options = {a: defaultA, b: defaultB}) and then when i call method(a: OtherA) to have the options hash = {a: otherA, b: defaultB}
[16:17:41] _bogus_: universa1, thanks !!
[17:59:30] _bogus_: Ping timeout: 244 seconds
[17:59:45] _bogus_: has joined #RubyOnRails
[19:54:36] _bogus_: can I have some help to install rvm / ruby / rails / passenger in my server ? im getting real headaches with this :/
[20:02:18] _bogus_: Radar, thanks.. any advises on rvm ? i cant install it system wide properly
[20:05:17] _bogus_: but i already have a ruby 1.8.7 installed which I cant modify (btw im not doing this on my machine but on a remote server which already contain things hosted and working)
[20:05:55] _bogus_: slash_nick, yes, ruby 4.2 needs higher version
[20:07:55] _bogus_: yes, is there any problems to install ruby-installer without uninstalling this 1.8.7 ?
[20:12:18] _bogus_: slash_nick, also, is this tutorial suitable for production server ?
[20:12:22] _bogus_: and the installation system wide ?
[20:43:06] _bogus_: Radar, i see, but is it ok for a production server? is the installation system wide ?
[20:43:16] _bogus_: to install this ruby-installer
[20:43:27] _bogus_: i personally use rvm in my machine but its for local user only
[20:45:20] _bogus_: Radar, another thing is I already installed passenger.. but the installer showed me 3 installations of apache (on /usr/bin/apache and /usr/local/bin/apache if im not wrong, and a third as backup).. i installed it on /usr/bin/apache just to discover the apache thats being used is the /usr/local/bin/apache one... but I think its not a problem right, as I've read it doesnt changes the apache installation, is that right ?
[20:45:46] _bogus_: Radar, not sure, this is a host server
[20:46:15] _bogus_: i asked them to upgrade the ruby but they said they wont because of incompability with cpanel, and gave me the root access to do what I want to do by my own risks
[20:46:54] _bogus_: yes but this is the client's host... there's already things hosted and working there :/
[20:47:27] _bogus_: ill give a try on your tut
[20:53:56] _bogus_: Radar, i did the first lines on the tutorial, but its installing ruby on ~/src/ruby-2.3.0 ...
[21:47:52] _bogus_: Read error: Connection reset by peer
[22:09:43] _bogus_: has joined #RubyOnRails
[22:10:02] _bogus_: any tutorials on how to deploy an app manually?

2016-03-08

[13:59:51] _bogus_: I was searching for CMS engines but I cant find a satisfatory solution...
[14:02:40] _bogus_: any ideas?
[14:14:54] _bogus_: please, does anybody knows a good gem to manage the content from already existing views of my app ??
[14:33:21] _bogus_: Read error: Connection reset by peer
[16:20:04] _bogus_: has joined #RubyOnRails
[16:54:21] _bogus_: please, does anybody knows a nice gem to manage content inside my views ?
[19:51:47] _bogus_: Read error: Connection reset by peer
[19:52:56] _bogus_: has joined #RubyOnRails
[21:54:49] _bogus_: Read error: Connection reset by peer
[22:34:43] _bogus_: has joined #RubyOnRails