fulcan

Activity Graph

Page 1 of 1

2017-04-03

[20:23:59] fulcan: has joined #RubyOnRails
[23:57:25] fulcan: Remote host closed the connection

2017-04-02

[00:12:41] fulcan: has joined #RubyOnRails
[00:12:47] fulcan: has joined #ruby
[00:36:36] fulcan: I am unable to start a rails projects https://bpaste.net/show/05446a28b013 I'm pretty sure my version is incorrect. will changing my ruby symlink to 2.3 fix it?
[01:05:39] fulcan: fryguy: same error without the rvm install
[01:33:07] fulcan: havenwood: i remove the rvm copy. same issue
[01:33:50] fulcan: bundle exec rails new palace -d mysql -> /usr/local/lib/ruby/site_ruby/2.3/rubygems.rb:270:in `find_spec_for_exe': can't find gem bundler (>= 0.a) (Gem::GemNotFoundException)
[01:35:12] fulcan: https://bpaste.net/show/c7b4b8ed452f
[01:39:03] fulcan: havenwood: rails is going in now. it looks like it was missing (got uninstalled)
[01:40:39] fulcan: havenwood: i'm a n00b with rails. expect st00pid err0rs. :)
[01:41:49] fulcan: havenwood: that worked!
[02:32:22] fulcan: I keep getting 'forbidden 403' trying to access my site https://bpaste.net/show/68c8b3adcea2
[02:33:21] fulcan: fryguy: I'm a n00b, not sure
[02:34:47] fulcan: fryguy: I started the project via rails
[02:36:02] fulcan: fryguy: 744 for dir, 644 for files
[02:38:24] fulcan: fryguy: changing it to public worked
[04:08:03] fulcan: error: Gem Load Error is: Could not find a JavaScript runtime https://bpaste.net/show/abe1db76285c
[04:11:09] fulcan: sevenseacat: nodejs is installed
[04:11:57] fulcan: also gem install execjs
[04:16:08] fulcan: sevenseacat: node is
[04:17:18] fulcan: fryguy: /usr/local/bin/node
[04:40:52] fulcan: fryguy: hmmm, I don't think I am. webserver user is www and rails user is user1
[13:57:49] fulcan: error: Gem Load Error is: Could not find a JavaScript runtime https://bpaste.net/show/fd0033f1dd01
[14:15:58] fulcan: fox_mulder_cp: it is install . note the bpaste
[14:58:17] fulcan: fuck ruby. can't turn it on? time for the delete button
[14:59:01] fulcan: has left #RubyOnRails: ("Once you know what it is you want to be true, instinct is a very useful device for enabling you to know that it is")
[22:06:01] fulcan: Quit: KVIrc 4.2.0 Equilibrium http://www.kvirc.net/

2017-03-31

[03:02:48] fulcan: Ping timeout: 260 seconds

2017-03-30

[03:26:03] fulcan: has joined #RubyOnRails

2017-03-29

[20:44:49] fulcan: has joined #RubyOnRails
[20:47:12] fulcan: I tried laravel but in order to 'use it' you have to pull is a full second computer. I couldn't get the crap to turn on anyways. So I deleted it. Next I tried Django but refuses to talk to apache so it just got deleted. Now I am looking at ruby. Is there a 'hello world' doc RoR that won't break me or my system?
[20:48:40] fulcan: I have Ubuntu and/or FreeBSD ready for the cooker.
[23:43:14] fulcan: Remote host closed the connection

2013-06-30

[01:43:11] fulcan: I am trying to start a new aplication and rails is stuck on an old aplication I already deleted. Routing Error No route matches [GET] "/courses/new" http://bpaste.net/show/pOWmaXYVXOxzwYYt5ckk/
[01:52:23] fulcan: my routes.rb http://bpaste.net/show/110844/
[02:08:31] fulcan: I am trying to start a new aplication and rails is stuck on an old aplication I already deleted. Routing Error No route matches [GET] "/courses/new" http://bpaste.net/show/pOWmaXYVXOxzwYYt5ckk/
[02:08:34] fulcan: my routes.rb http://bpaste.net/show/110844/
[02:13:26] fulcan: ActionController::RoutingError (No route matches [GET] "/courses/new"): I deleted that project, why is rails still pointed to it? I have certainly restarted the server??
[02:19:52] fulcan: fgo where would it be hidden? http://bpaste.net/show/1cbWsHFeG9G1JmV8gdFg/
[02:23:21] fulcan: fgo yes. i'm an idiot
[04:28:31] fulcan: how do you get rid of this error? You have already activated rake 10.1.0, but your Gemfile requires rake 10.0.3. Using bundle exec may solve this.

2013-06-29

[00:41:33] fulcan: couldn't find file 'jquery.ui.all' when trying to connect to http://50.116.34.222:3000/ which appears to be a known issue, I added *= require jquery.ui.all to application.css and //= require jquery.ui.all to application.js but still get the error. complete build and error -> http://bpaste.net/show/3yC1AZxq5WmSTzHHTE4d/
[00:45:43] fulcan: superscott[8] you mean require jquery.ui.all ?
[00:49:14] fulcan: superscott[8] same thing
[00:50:10] fulcan: ActionView::Template::Error (couldn't find file 'jquery.ui.all'
[00:50:36] fulcan: I don't think I ever had it
[00:51:06] fulcan: how/where do I get it?
[00:57:30] fulcan: superscott[8] I am trying to figure it out. I am very new to ruby and trying to get this running https://github.com/lockitron/selfstarter/blob/master/README.md
[00:58:29] fulcan: superscott[8] I think I am doing this wrong.
[01:08:39] fulcan: superscott[8] how do I install jquery-ui-rails? I git it and run bundle install and do the same in selfstarter, but still getting the same error? I am missing something foolish.
[01:20:06] fulcan: how do you install a gem from github i they don't have a .git file? gem 'jquery-ui-rails', :git => "git://github.com/joliss/jquery-ui-rails.git" bash: git://github.com/joliss/jquery-ui-rails: No such file or directory ?
[01:29:15] fulcan: rake aborted! http://bpaste.net/show/ON4RTUvFBD3uurHZStoE/
[01:59:57] fulcan: rake aborted! http://bpaste.net/show/ON4RTUvFBD3uurHZStoE/ I found this https://github.com/refinery/refinerycms/pull/1773 but I added <%# encoding: utf-8 %> to all my .yml files and still the same characterset error.
[02:02:53] fulcan: build_info = JSON.parse(File.read build_file)
[02:04:25] fulcan: Radar I'm not real sure. I am very new to ruby
[02:06:22] fulcan: http://bpaste.net/show/110636/
[02:07:33] fulcan: ruby 1.9.3p429 (2013-05-15 revision 40747) [x86_64-linux]
[02:10:36] fulcan: Radar is there any way around this error without jquery-ui-rails ? http://stackoverflow.com/questions/17374842/ruby-on-rails-ails-with-couldnt-find-file-jquery-ui-all
[02:13:08] fulcan: https://github.com/lockitron/selfstarter
[03:13:20] fulcan: if ruby on rails is port 3000, does passenger parse it to port 80?
[03:19:15] fulcan: whats the best tool to use for setting up a payment system with the gateway Stripe?

2013-06-28

[05:24:36] fulcan: I am a total rails n00b http://bpaste.net/show/tKKi4TCutOKIyIZYtYrt/
[05:25:06] fulcan: trying to install https://github.com/lockitron/selfstarter/
[05:25:34] fulcan: I suck at git too.
[05:29:00] fulcan: rake aborted!
[05:29:00] fulcan: li424-222 selfstarter # bundle exec rake db:migrate|wgetpaste
[05:29:01] fulcan: No input read. Nothing to paste. Aborting.
[05:29:01] fulcan: (See full trace by running task with --trace)
[05:29:01] fulcan: Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes.
[05:31:26] fulcan: I appologize for the multiline paste. installing nodejs now (what I think is my gentoo javascript runtime)
[05:33:27] fulcan: rvanlieshout I think it worked.
[05:36:05] fulcan: this is the error I was trying to get around. http://bpaste.net/show/3Md2iJTihCcFQ6TbQfVz/ how do I downgrade rack?
[05:38:04] fulcan: gja thank you! checking now.
[05:45:54] fulcan: gja I am confused, rake it what is erroring.
[05:46:48] fulcan: http://bpaste.net/show/HgnA8l6qSZcqw8849vT4/
[05:48:47] fulcan: I am very new to rails. I see this -> 10.0.3. Using bundle exec may solve this. but not sure how to downgrade. it this a package management system thing?
[05:52:04] fulcan: how do you install an app from git? I find no docs to support this.
[05:53:17] fulcan: everything on github but nobody knows how to install, great.
[05:54:35] fulcan: gja huh? http://bpaste.net/show/8GECF6YDj0qxOqsYoPWD/
[05:55:14] fulcan: sevenseacat no execute button. the question is valid.
[05:55:32] fulcan: no execute command
[05:58:52] fulcan: I don't know where I went wrong http://bpaste.net/show/6m7GCABj2mHh47CXp5MD/
[06:00:31] fulcan: sevenseacat please, I am working with rails for the first time. of course I read it, the error means something to you, not me.
[06:03:22] fulcan: sevenseacat I am waiting for the rest sir.
[06:04:10] fulcan: prefix the commands you're calling with `bundle exec`.
[06:04:18] fulcan: and???....
[06:05:02] fulcan: bundler: exec needs a command to run
[06:06:37] fulcan: sevenseacat no sir! http://bpaste.net/show/FVlvcBNEUU24qHSZrfy0/
[06:08:22] fulcan: sevenseacat I add lib nothing. straight copy/paste. I am 'that' new.
[22:46:32] fulcan: gem install 'jquery-rails', '< 3.0.0' -> ERROR: Could not find a valid gem 'jquery-rails,' (>= 0) in any repository
[22:46:40] fulcan: couldn't find file 'jquery.ui.all' which is a known issue, I added *= require jquery.ui.all to application.css and //= require jquery.ui.all to application.js but still get the error. http://bpaste.net/show/1RqTDUte2XLBoj8fdTbf/
[23:05:13] fulcan: couldn't find file 'jquery.ui.all' which is a known issue, I added *= require jquery.ui.all to application.css and //= require jquery.ui.all to application.js but still get the error. http://bpaste.net/show/1RqTDUte2XLBoj8fdTbf/
[23:33:37] fulcan: couldn't find file 'jquery.ui.all' which is a known issue, I added *= require jquery.ui.all to application.css and //= require jquery.ui.all to application.js but still get the error. http://bpaste.net/show/1RqTDUte2XLBoj8fdTbf/