in a gemspec, is it "legal" to have runtime dependencies depend on RUBY_VERSION? See line 17 of https://github.com/AuthorizeNet/sdk-ruby/blob/master/authorizenet.gemspec - bundler won't let you install that with activesupport/rails > 4.2.6.
rubygems.org also shows it locked to activesupport 4.2.6 https://rubygems.org/gems/authorizenet
Trying to figure out if that's just a bad gemspec I should submit a PR on, or if there's a problem with rubygems/bundler
I would try 2.4.1 and if that seems too ugly, go to 2.3.4. I have upgraded some pretty nasty stuff to 2.3 without incident, but 2.4 has had issues with a couple gems I used