siaW

Activity Graph

Page 1 of 16 | Next »

2016-07-25

[06:07:32] siaW: has joined #RubyOnRails
[08:03:39] siaW: has left #RubyOnRails: ()

2016-07-24

[05:32:44] siaW: has joined #RubyOnRails
[15:14:08] siaW: Quit: siaw
[19:01:22] siaW: has joined #RubyOnRails
[21:29:02] siaW: Quit: siaw
[21:29:13] siaW: has joined #RubyOnRails
[21:58:33] siaW: Quit: siaw

2016-07-23

[10:02:10] siaW: has joined #RubyOnRails
[15:55:46] siaW: Quit: siaw
[19:10:59] siaW: has joined #RubyOnRails
[21:50:29] siaW: Quit: siaw

2016-07-22

[17:11:25] siaW: has joined #RubyOnRails
[17:16:14] siaW: i’m got back to my R4IA book but have problems with this failure: https://gist.github.com/siaw23/410741293602565421ae8df6a91826f2#file-console-txt
[17:16:38] siaW: it’s complanining it can’t find field "File #2" and i’m not sure why. any ideas?
[17:27:26] siaW: Mirubiri: https://gist.github.com/siaw23/410741293602565421ae8df6a91826f2#file-_attachment_form-html-erb
[17:42:16] siaW: Mirubiri: yes and i’m not sure why
[17:42:29] siaW: in the tutorial it seems to work for them i believe
[17:48:55] siaW: no. it’s not uploaded until i submit the form
[17:50:18] siaW: but should it be uploaded instantly?? what if the user has more files to attach? and if you mean instant, then how can the app know which ticket the attachment is for?
[17:51:12] siaW: rails 4 in action
[17:52:29] siaW: oh. now i’m ont page 386 (11.1.2)
[17:52:36] siaW: i left that error to move on with the rest
[17:52:43] siaW: but i can find that section for you in a bit
[17:53:31] siaW: Mirubiri: page 316 (9.4.4)
[17:54:09] siaW: Mirubiri: my repo is here: https://github.com/siaw23/ticket_tracker
[17:59:59] siaW: Mirubiri: that’s not it
[18:00:11] siaW: unfortunately :(
[18:05:07] siaW: Mirubiri: that’s not it :(
[18:05:17] siaW: tubbo: i’m checking
[18:07:10] siaW: tubbo: when i’m testing for the creating of a new ticket
[18:08:46] siaW: right!!!
[18:08:51] siaW: it’s in the wrong folder
[18:13:06] siaW: i put it in the right folder. same error though.
[23:29:25] siaW: Quit: siaw

2016-07-17

[00:42:03] siaW: has joined #RubyOnRails
[14:29:12] siaW: Quit: siaw
[21:51:41] siaW: has joined #RubyOnRails
[22:21:17] siaW: has left #RubyOnRails: ()

2016-07-16

[03:02:09] siaW: has joined #RubyOnRails
[04:47:17] siaW: if someone knows a bit a bout react/rails and can help: http://stackoverflow.com/questions/38407809/expose-model-data-in-component please do :)
[13:21:42] siaW: if someone can help: http://stackoverflow.com/questions/38411542/submitting-a-form-to-rails-with-reactjs :)
[15:07:26] siaW: can someone who knows a bit about React help me out: http://stackoverflow.com/questions/38411542/submitting-a-form-to-rails-with-reactjs
[15:27:03] siaW: Quit: siaw
[19:06:54] siaW: has joined #RubyOnRails
[19:30:40] siaW: if someone who knows react can help :) http://stackoverflow.com/questions/38411542/submitting-a-form-to-rails-with-reactjs
[19:37:40] siaW: Quit: siaw

2016-07-15

[22:04:48] siaW: has joined #RubyOnRails
[22:07:24] siaW: hello i need help. i am using react-rails gem currently my url that points to users.json returen something like this
[22:07:25] siaW: https://gist.github.com/siaw23/1ee63f0db8e7964761e1660d7f44296d
[22:07:31] siaW: is this normal?
[22:08:06] siaW: i can see some records from my db in that file but the formatting has some strange “"” stuff that i don’t know how to handle
[23:39:33] siaW: Quit: siaw

2016-05-03

[10:09:01] siaW: Quit: siaw

2016-05-02

[01:56:50] siaW: Quit: siaw
[07:58:34] siaW: has joined #RubyOnRails
[07:58:34] siaW: has joined #ruby
[08:05:35] siaW: Quit: siaw
[08:10:28] siaW: has joined #RubyOnRails
[08:10:28] siaW: has joined #ruby
[09:32:16] siaW: Quit: siaw
[10:10:19] siaW: has joined #RubyOnRails
[10:10:19] siaW: has joined #ruby
[10:10:59] siaW: Client Quit
[10:11:28] siaW: has joined #RubyOnRails
[10:11:28] siaW: has joined #ruby
[11:31:00] siaW: i cloned a repo and did ‘bundle install’ and everything was ok. for some reason i tried to do ‘bundle install’ again after cloning the same repo and i get https://gist.github.com/siaw23/41be220cf01a5b68da22e91fbf12fa69
[11:31:40] siaW: i have no idea what ‘ruby_dep’ does but it’s saying it require ruby versions above 2.2 and the repo has it’s ruby set to 2.0
[11:32:40] siaW: and i’m not sure how to get rid of it.
[11:44:28] siaW: yes i did that and i get https://gist.github.com/siaw23/41be220cf01a5b68da22e91fbf12fa69#file-install-txt
[11:45:13] siaW: it’s require ruby 2.2, but previous ‘bundle install’ didn’t got through this
[11:46:18] siaW: the ruby version of the repo is set to 2.0, if i change to a higher version, there’s a whole lot of mess
[11:46:57] siaW: sevenseacat: yes, https://github.com/berkmancenter/lumendatabase
[11:47:11] siaW: that’s what i cloned
[11:49:11] siaW: i remove ‘therubyracer’ gem from it
[11:49:21] siaW: and also paperclip gem
[11:50:43] siaW: i also set ‘rails_admin’ gem to the latest one
[11:51:29] siaW: i won’t :D
[11:51:42] siaW: buuut in that Gemfile
[11:51:54] siaW: there’s this gem ‘gem 'paperclip', git: 'http://github.com/thoughtbot/paperclip.git'
[11:52:11] siaW: which will grab the latest version of paperclip right?
[11:52:14] siaW: from their repo
[11:52:25] siaW: when i try to do bundle install
[11:52:43] siaW: what if i don’t have a gemfile.lock?
[11:52:49] siaW: i deleted it
[11:52:52] siaW: just now
[11:53:31] siaW: because i was having problems that i wanted to solve myself
[11:53:39] siaW: i’ll just reclone the repo and start from scratch
[11:56:20] siaW: sevenseacat: after recloning see the kind of error i’m getting https://gist.github.com/siaw23/41be220cf01a5b68da22e91fbf12fa69
[11:56:39] siaW: on this line https://gist.github.com/siaw23/41be220cf01a5b68da22e91fbf12fa69#file-bundle_install-txt-L107
[11:57:10] siaW: i did that already
[11:57:32] siaW: the fix is to remove therubyracer gem
[11:57:41] siaW: having nodejs installed is enough
[11:58:04] siaW: because i didn’t finish typing the problem yet :)
[13:40:23] siaW: i’m getting “Mysql2::Error: Specified key was too long; max key length is 3072 bytes: ALTER TABLE `infringing_urls` CHANGE `url` `url` varchar(8192) NOT NULL” on https://gist.github.com/siaw23/57315de8132c1f490487ed9e5e862f6f#file-schema-rb-L116 and the migration looks like this: https://gist.github.com/siaw23/57315de8132c1f490487ed9e5e862f6f#file-some_migration-rb how can i fix this?
[13:43:22] siaW: in the migration?
[13:43:28] siaW: don’t i need to create a new migration for this?
[13:44:14] siaW: the migration was successful until the point where it needed to create this table in question
[13:44:55] siaW: no. i haven’t touched it
[13:45:01] siaW: since i cloned the repo
[13:45:46] siaW: ok testing
[13:47:02] siaW: no it’s not working, same error
[13:51:04] siaW: no worries :)
[18:29:18] siaW: Read error: Connection reset by peer

2016-05-01

[08:19:31] siaW: Quit: siaw
[08:26:30] siaW: has joined #RubyOnRails
[08:26:30] siaW: has joined #ruby
[08:29:23] siaW: Client Quit
[08:56:47] siaW: has joined #RubyOnRails
[08:56:47] siaW: has joined #ruby

2016-04-30

[01:31:11] siaW: has joined #RubyOnRails
[01:31:11] siaW: has joined #ruby
[02:18:55] siaW: Quit: siaw
[02:20:18] siaW: has joined #RubyOnRails
[02:20:18] siaW: has joined #ruby
[02:38:14] siaW: Quit: siaw
[07:37:03] siaW: has joined #RubyOnRails
[07:37:03] siaW: has joined #ruby
[07:57:37] siaW: good day. i’m interested in what you read as a good book on Rails. any good recommendations here? I already finished Michael Hartl’s stuff and currently reading Rails 4 in Action
[08:34:55] siaW: Quit: siaw
[08:37:12] siaW: has joined #RubyOnRails
[08:37:12] siaW: has joined #ruby
[08:40:53] siaW: Client Quit
[08:46:13] siaW: has joined #RubyOnRails
[08:46:13] siaW: has joined #ruby
[10:32:49] siaW: Quit: siaw
[10:33:12] siaW: has joined #RubyOnRails
[10:33:12] siaW: has joined #ruby
[10:49:09] siaW: :). thanks. i’m checking them out now
[10:55:34] siaW: tildes: what’s the gem url, just want to look at it
[11:25:04] siaW: tildes: ok
[15:06:51] siaW: Quit: siaw
[20:47:35] siaW: has joined #RubyOnRails
[20:47:35] siaW: has joined #ruby

2016-04-29

[10:57:59] siaW: has joined #RubyOnRails
[10:57:59] siaW: has joined #ruby
[10:59:05] siaW: is there a way i can have an array of size, say, 2. but anytime i do #shift, the new item is first element in array but the item at position 1, gets removed?
[10:59:32] siaW: example. array = [“one”, “two”]
[10:59:43] siaW: array.shift(“three”)
[10:59:51] siaW: i want something like this to be returned
[11:00:04] siaW: array = [“three”, “one”]
[11:00:14] siaW: so that the size of the array is ALWAYS 2
[11:01:03] siaW: Ox0dea: i was thinking about that. but thought there’d be a more “elegant” way
[11:01:49] siaW: yeah right
[11:17:33] siaW: Quit: siaw
[14:14:31] siaW: has joined #RubyOnRails
[14:14:31] siaW: has joined #ruby
[14:15:16] siaW: i have a problem
[14:15:27] siaW: when i do “gem uninstall rails”
[14:15:44] siaW: its shows me all versions of rails
[14:15:52] siaW: so i choose to unistall all versions
[14:15:55] siaW: but when i do
[14:16:22] siaW: gem install rails -v 4.2.6 it always intsalls the latest rails 5 beta. which i don’t want
[14:18:27] siaW: please see the sequence of my commands and what i’m getting https://gist.github.com/siaw23/9c484589279e2d9815617c5c203ec6be
[14:18:51] siaW: even after installing all rails versions. if i do rails -v i sill get Rails 5 beta
[14:20:16] siaW: sevenseacat: yes i have
[14:20:35] siaW: same thing
[14:20:51] siaW: https://gist.github.com/siaw23/9c484589279e2d9815617c5c203ec6be
[14:21:00] siaW: yeap. just updated logs
[14:22:31] siaW: no that’s not working https://gist.github.com/siaw23/9c484589279e2d9815617c5c203ec6be#file-console-txt-L79
[14:23:25] siaW: maybe i’ll format my computer 😂
[14:24:25] siaW: if anyone has any idea how to get Rails 5 beta off my computer i’ll appreciate it
[14:25:02] siaW: this is a problem with rails 5?
[14:25:15] siaW: or with RubyGems?
[14:28:09] siaW: this is weird
[14:28:11] siaW: now look
[14:28:12] siaW: https://gist.github.com/siaw23/9c484589279e2d9815617c5c203ec6be
[14:28:18] siaW: it STILL has rails 4.2.6
[14:28:47] siaW: which is what i want, but why it shouldn’t be there after i do “gem uninstall rails” and then choose the option to uninstall all versions
[14:34:56] siaW: thanks, figured it out
[14:35:26] siaW: now i want to be able to set a spefic rails version and ruby version for a given rails app.
[14:35:51] siaW: i’d need to put a file to specify this in the rails app, is that correct?
[14:37:21] siaW: i google anything first before i come here. if i’m here means i couldn’t find it with google’s help
[14:37:41] siaW: and i learned about .ruby-version from google
[14:37:52] siaW: but that only sets the ruby version,
[14:38:09] siaW: and when i asked now i know the Gemfile can do both ruby and rails version
[14:38:31] siaW: roamingdog: now i know. i didn’t know this from google
[14:39:30] siaW: no, i’m not stupid. but sometimes i try to know that i KNOW than act that i know and then be wrong
[14:40:12] siaW: and i’m not ashamed of asking stupid questions romaingdog, if you can answer, great, i’ll be thankful. if not, i’m sure people who come here are from google and can’t figure stuff out
[14:40:59] siaW: you see? and now it appears it’s more complicated that it seems
[14:43:41] siaW: roamingdog: sometimes if you don’t know much about a subject, you don’t even know what to google. especially technical stuff. not sure if you’ve experienced this before, if not, then i’m extremely jealous of you!
[14:45:26] siaW: sevenseacat: yeap. if you know what to google :)
[15:59:05] siaW: has left #ruby: ()
[15:59:06] siaW: has left #RubyOnRails: ()
[16:03:27] siaW: has joined #ruby
[16:03:33] siaW: has left #ruby: ()
[16:03:43] siaW: has joined #RubyOnRails
[16:05:47] siaW: i’m trying to start a rails 3.2 app. I get this error after running “./bin/setup”. i’m following the instructions on here https://github.com/siaw23/lumendatabase/blob/dev/README.md and this is the error i’m getting https://gist.github.com/siaw23/37136570db10cde88fb0d285fabe01d8 i have googled “Gem::Ext::BuildError: ERROR: Failed to build gem native extension.” but it looks like this is a comon problem to a lot of other thing
[16:05:48] siaW: any help would be cool.
[16:11:29] siaW: roamingdog: problem is i already have nodejs installed. so maybe i have to remove “therubyracer” from gem lock
[16:11:32] siaW: let me try that first
[16:23:48] siaW: roamingdog: works
[16:24:11] siaW: but trying to start forman and this is what i get https://gist.github.com/siaw23/37136570db10cde88fb0d285fabe01d8
[16:24:18] siaW: if you look on line 4
[16:24:52] siaW: you see gdbm, that also appears to be a common problem with different cause maybe you know how to tacklet that?
[16:30:26] siaW: bundle exec foreman start doesn’t work same error. also i have tried commenting out the part where it’s requiring gdbm and get /Users/siaw/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.11.2/lib/bundler/runtime.rb:80:in `rescue in block (2 levels) in require': There was an error while trying to load the gem 'mysql2'
[16:35:11] siaW: tubbo: right
[16:36:14] siaW: as can be seen here: https://gist.github.com/siaw23/37136570db10cde88fb0d285fabe01d8#file-bundle-txt
[16:36:16] siaW: everything installed
[16:36:53] siaW: it points to /Users/siaw/.rvm/gems/ruby-2.0.0-p247/bin/foreman
[16:38:44] siaW: you mean gdbm?
[16:38:59] siaW: i don’t know, i can’t tell
[16:39:34] siaW: yes i added it and it works.
[16:39:46] siaW: no it wasn’t in the gemfile before
[16:39:57] siaW: just added it
[16:40:17] siaW: no no it wasn’t in the gemfile at all
[16:40:20] siaW: i just added it
[16:40:21] siaW: right now
[16:41:05] siaW: ah. that was in application.rb on line 10
[16:41:55] siaW: ah ok :)
[16:45:50] siaW: roamingdog: i do
[16:45:54] siaW: everything is working now
[16:46:02] siaW: not seeing new errors with i’m trying to fix
[16:46:38] siaW: the fix was adding gdbm to the gemfile
[16:57:52] siaW: it’s strange because this is a fork
[22:58:25] siaW: Quit: siaw

2016-04-28

[10:17:33] siaW: Ping timeout: 240 seconds
[10:18:27] siaW: has joined #RubyOnRails
[10:18:27] siaW: has joined #ruby
[12:20:19] siaW: Quit: siaw

2016-04-27

[16:01:57] siaW: i’m using javascript do do infinte scrolling and it’s working locally but not on heroku, any ideas?
[16:03:41] siaW: context, heroku has no errors. and console has no errors either
[16:04:15] siaW: locally when i scroll down, more stuff loads. on heroku nothing loads
[16:06:15] siaW: context: https://evening-beyond-84055.herokuapp.com/
[16:06:50] siaW: context: on my github https://github.com/siaw23/devsnap
[16:07:08] siaW: context: yes i get it locally too but works anyway
[16:08:20] siaW: i have no idea
[16:08:39] siaW: context: where are you seeing that?
[18:10:24] siaW: Ping timeout: 276 seconds
[18:18:25] siaW: has joined #RubyOnRails
[18:18:25] siaW: has joined #ruby
[18:29:37] siaW: Ping timeout: 244 seconds
[18:29:57] siaW: has joined #RubyOnRails
[18:29:57] siaW: has joined #ruby