tjj

Activity Graph

Page 1 of 1

2019-06-07

[06:53:41] tjj: has joined #ruby
[08:13:10] tjj: Ping timeout: 272 seconds
[08:14:40] tjj: has joined #ruby
[08:33:27] tjj: Ping timeout: 252 seconds
[08:41:50] tjj: has joined #ruby
[10:13:01] tjj: Quit: Leaving

2019-05-21

[08:58:25] tjj: has joined #ruby
[09:03:48] tjj: Ping timeout: 245 seconds
[09:05:02] tjj: has joined #ruby
[09:25:11] tjj: Remote host closed the connection
[09:25:31] tjj: has joined #ruby
[09:32:01] tjj: Ping timeout: 258 seconds

2019-05-18

[02:04:19] tjj: Remote host closed the connection

2019-05-17

[08:39:29] tjj: has joined #ruby
[08:47:35] tjj: Ping timeout: 258 seconds
[09:01:01] tjj: has joined #ruby
[09:11:36] tjj: Ping timeout: 268 seconds
[13:43:47] tjj: has joined #ruby
[20:10:01] tjj: Ping timeout: 255 seconds
[20:21:28] tjj: has joined #ruby
[21:22:17] tjj: Remote host closed the connection
[21:22:41] tjj: has joined #ruby
[22:09:44] tjj: Ping timeout: 252 seconds
[23:34:27] tjj: has joined #ruby
[23:52:40] tjj: Remote host closed the connection
[23:56:33] tjj: has joined #ruby

2019-05-16

[15:18:45] tjj: has joined #ruby
[16:06:20] tjj: tried googling around and posting on #nokogiri too, but didn't help. Can someone please please help here ?
[16:06:20] tjj: Hi Folks, I am trying to install nokogiri gem. Flushed the DNS cache just to be sure since it had created issues in the past and ran 'gem update --system' which worked successfully. Then I tried installing nokogiri with command 'gem install nokogiri' - and its failing to open a TCP/IP connection to zlib.net:80. Hence possibly failing to build gem native extension. Have pasted the gem env, gem_make.out and mkmf.log below. Machine is not behind a proxy or a firewall.
[16:06:34] tjj: https://gist.github.com/tejasInSiberia/08e4288b0e1cf3fbda9a61af58a8865b
[16:13:17] tjj: yes, I can open zlib.net in the browser
[16:17:09] tjj: adam12 : The page for zlib.net shows up properly in the browser, Not able to understand what's happening while building the gem
[16:19:21] tjj: but 'gem update --system' worked correctly and it fetched all it needed. Sure - should try with irb once
[16:21:20] tjj: is zlib.net known to have some specific TLS version requirement ? currently I have set up --> [Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12
[16:29:57] tjj: adam12: It doesn't work on Windows. I downloaded nokogiri locally and tried 'gem install --force --local nokogiri-1.10.3.gem'. But it has to connect to zlib.net. it fails with the same error.
[16:32:56] tjj: adam12 | balo : Why does is even connect to zlib site while building ? can I download and provide, whatever dependency is, locally along with the gem to solve this ?
[16:37:36] tjj: balo: does that mean if I place the file in that folder, it wouldn't at all connect to zlib site ??
[16:51:48] tjj: Not even able to locate the tar file on zlib. there are a lot of Windows versions too. Should be suitable for Win10
[16:53:23] tjj: oh. its https://zlib.net/zlib-1.2.11.tar.gz
[17:01:00] tjj: Keeping the zlib tar file at the mentioned location isn't working. As soon as I paste and trigger the local installation command - all tar files at the location suddenly vanish. (There are 2 files already and I copied the 3rd). 2 re-appear after certain time but zlib tar file vanishes. Well, these are getting creating through the process, just placing doesn't work.
[17:01:31] tjj: created#
[17:02:27] tjj: any ideas for spotting shell-to-network issues ? :/
[17:03:22] tjj: I am able to wget https://zlib.net/zlib-1.2.11.tar.gz with OK 200
[17:03:39] tjj: through this shell
[17:17:53] tjj: thanks a lot adam12 and balo. I give for today :)
[17:18:22] tjj: I give up for today# :|
[17:18:31] tjj: Quit: Leaving

2019-05-02

[10:05:31] tjj: has joined #ruby
[10:15:41] tjj: hi folks.. I have been using Ruby plugin within Apache Netbeans 10. I had my Ruby env configured to use FastDebugger. Suddenly out of nowhere I am getting this error msg
[10:15:44] tjj: https://pastebin.com/j5tgk23E
[10:18:05] tjj: any help would be appreciated
[10:19:31] tjj: and most important - it says Could not find 'nokogiri' (~> 1.10) - did find: [nokogiri-1.8.0-x64-mingw32]
[10:19:56] tjj: kind of joking I guess.. 1.8 is > 1.10
[12:40:42] tjj: Remote host closed the connection