Page 1 of 2 | Next »
[08:09:12] tuor: hi, I have installed the rvm package from the ppa: ppa.launchpad.net/rael-gc/rvm/ubuntu/.
[08:11:23] tuor: Now I have tried to install ruby with rvm, but I got a lot of erros like this: tar: binscripts: Cannot utime: Operation not permitted
[08:23:57] tuor: Knappe: checkout https://freenode.irclog.whitequark.org/ruby/2018-09-10 for the history of yersturday
[06:51:28] tuor: (my setup: Ubuntu 16.04) Hi, I have installed gem with sudo and now I always need sudo to install gems. How can I remove all gems and start over with all my gems in my $HOME? So I don't require sudo to install gems....
[07:08:40] tuor: I want to be able to install gems an use bundle and rake in my home without sudo. What do I have to do?
[07:12:24] tuor: I'm the only user of this laptop. Can I install ruby in a way, that gem, bundle, rake, what ever is all handled inside my home by default?
[10:36:52] tuor: hi, what gem would you use for managing keepass databases? (I know there are multiple but which one do you recomend?)
[14:05:24] tuor: jhass, so I tried to improve my code: https://gist.github.com/nod0n/d01024a5b6aecab2b1c7
[14:09:02] tuor: For all the people which help me a time ago to improve my code, here is a new version of my class: https://gist.github.com/nod0n/d01024a5b6aecab2b1c7
[14:10:57] tuor: I tried to improve some stuff, but I know error handling is mostly missing and it's still not logging. Apart from this, what would you improve/change?
[14:17:31] tuor: The thing is, it's using a gem for using the zabbix api. This class should give the missing possibility of the ZabbixApi gem.
[14:18:02] tuor: certainty, ok. I'll think about how to separate them. But when they need the same code (some methods) what do I do then?
[14:19:03] tuor: ok. Then i should make one class for the shared stuff, and one for each function (import | export).
[08:42:01] tuor: hi, when i have a if statement with only one line in it (like: if true; do_this; end) but it's to long to write it on one line (more the 80 letters), should I write it with "if ...;..;end" or "... \;if ..." ?
[08:50:27] tuor: This is a method from my code: https://gist.github.com/anonymous/3419030c49b780c29716
[08:51:44] tuor: jhass, can you explain what you meen (with the new code example), I don't understand it.
[08:55:00] tuor: the difference between the two pastes is what i meen. I would like to write like in the second one (on one line) but it's to long. So the question is: is it ok to write it like this: https://gist.github.com/anonymous/acdd9af77c53de966673
[09:04:19] tuor: jhass, the other lines need to be in the first if statement to. (check_key_string is a method which checks if the param1 is a hash, if the key param2 exists and if the value of the key param2 is a not empty string.) I don't know how to call it... It's because options can be set or not and if they are set, they should be the correct datatype.
[09:22:54] tuor: jhass, ok the abstraction thing would be biger changes, so i begin with the other stuff. I'll be back.
[10:13:07] tuor: jhass, so i did some changes: https://gist.github.com/anonymous/b63c98f2f204fd75ce98 (I don't know how to show diff between 2 pastes....)
[10:17:56] tuor: jhass, better looking... https://gist.github.com/nod0n/e9db3cb04b4eb5557027/revisions
[10:18:32] tuor: jhass, i didn't change the names of all the methods because i want to rethink about how to do it and then directly rewrite with better names.
[10:20:03] tuor: To assign to @templates_list comes with how I used it befor. I just didn't removed it (because I don't checked if it's realy changed every where)
[10:28:01] tuor: jhass, so the list_templates is cleaned a little bit up: https://gist.github.com/nod0n/e9db3cb04b4eb5557027
[10:29:44] tuor: I'll have a breake and then try to rewrite the options stuff. Cu later. Thx for your help jhass! :)
[07:36:25] tuor: It's about read_config_file. The file exists but the code l130 isn't run. I tryed to start pry and include the class. I created a instance of it and called the method but config_file is still an empty Hash.
[07:37:03] tuor: I don't get any syntax error. Now I just don't know how to find out what is going wrong...
[07:38:15] tuor: What I want with this method (if it's not clear): read a YAML file and create a ruby hash object wich contains (for the moment) only one key
[07:45:57] tuor: I tried it "manualy" in pry there it works: https://gist.github.com/anonymous/41124d7df7a451886c2a
[07:56:38] tuor: certainty, I did it so (just for not speaking of different thing): https://gist.github.com/anonymous/e00d3493020555a20458
[08:05:49] tuor: certainty, hmm ok. I tried this: https://gist.github.com/anonymous/8d9f7a13be0bfaef9f10
[08:16:48] tuor: ah found. Man it's not the problem of the class. It's the script using it which gives an empty string as the second argument.
[13:05:29] tuor: New general question: is it "good"/"ok"/"bad" to use methods to acces and set object variables? Should i have this for all my object variables? (like this: https://gist.github.com/anonymous/2b7e1b224cd04057315f)
[13:06:02] tuor: and use in the same class only the methods and don't acces directly the variable with @myvar
[13:12:39] tuor: So what I do in the class is up to me, so long I do it the same in the complete class. I give accessors if needed.
[15:59:54] tuor: hi, I have finished the first version of my "mini gem". It's just one thing and it's based on an other one. So this is the code: https://gist.github.com/anonymous/1573a0036fa6605c3e54
[16:01:17] tuor: it's my first ruby programm. My first (more the 10 line) programm. I know bash but that's it. So pleas tell me what you would do better or so. thx. :)
[16:03:01] tuor: it's working. So review^^ I mean if someone has time. Or just review "fast". Or just how the syntax is.
[16:14:16] tuor: [k-_, thats the normal username when you install. So if you want to test then it works. When you use it, you give your own stuff to .new()
[16:15:47] tuor: atmosx, I don't understand why not using variables. ( I wouldn't use instance variabels in teh code, I'd use attr_reader to depend on behavior not ata)
[16:30:00] tuor: ACTION will slowly go over all you wrote and thx for so much answers! Tuor will later post the changed code.
[17:14:35] tuor: OK. I think i have done the changes. The code still works. :): https://gist.github.com/anonymous/2e0ad8ed1fb72e97913a
[17:16:19] tuor: atmosx, a logger & error handling will be a bigger task, can't do it in 5 min. So I'll do it in future. (it's on my list now)
[17:17:23] tuor: mikecmpbll, "18:14:54 use the json style hash syntax for symbolic keys" I don't understand what you meen.
[17:20:05] tuor: atmosx, "judging by your code, I think you're kinda ready to read this book...": I have a book about ruby basics. I'll have to read (and train) this one first. But Then I'll see (I have it in a bookmark)
[17:24:51] tuor: havenwood, just forgott about this one, but why DEFAULT_RULES and not RULES_DEFAULT? I meen I just like to write names like this. So is it important which way?
[17:28:17] tuor: havenwood, no, but it's just about rules and there are the default ones. So the name begins with rules and default is just an aditional information about which rules. ;)
[14:07:39] tuor: adaedra, ok. I use vim at the moment. But I like to move to a grahpical editor (nicer look) and little features.
[14:19:09] tuor: I don't *need* more. vim can do all I need (I think). It's about looking and how to work. I know vim and gvim. I use vim since over a year. I just want to try other stuff.
[13:20:36] tuor: [k-_, I don't get what you say. Can you tell me what I have to search online for understanding what you write?
[13:23:12] tuor: jhass, yes. Then i does a litle less disk IO. But I don't realy know which would be faster. Both is ok.
[13:25:01] tuor: [k-_, no checks aren't but when there is code which is not need, then why not remove it.
[14:17:11] tuor: when I call importe_templates i get the error: "undefined method `inlcude?' for :Array" https://gist.github.com/anonymous/38d02db914db7a8ce916