umdstu

Activity Graph

Page 1 of 6 | Next »

2017-11-05

[14:28:35] umdstu: has joined #RubyOnRails
[14:30:12] umdstu: i’m having some trouble debugging a custom route for carrierwave image uploads. it keeps telling me the route doesn’t exist so i’m curious how it’s ‘seeing’ the route coming through (broken down by params)
[14:31:08] umdstu: GET /uploads/estimate_attachment/repair_image/:id/:filename(.:format) ..versus.. Started GET "/uploads/estimate_attachment/repair_image/6/thumb_Screen_Shot_2017-11-05_at_8.56.37_AM.png"
[14:33:55] umdstu: i now believe it’s the periods in the filename (the time) that is breaking the route definition
[14:39:21] umdstu: yea that was it, nvm. added constraints to allow dots
[14:40:56] umdstu: now it just can’t find the file, awesome
[15:23:49] umdstu: Quit: umdstu

2017-11-03

[01:01:31] umdstu: has joined #RubyOnRails
[01:01:33] umdstu: Client Quit

2017-11-02

[22:49:50] umdstu: has joined #RubyOnRails
[23:06:07] umdstu: Quit: umdstu

2017-11-01

[01:18:25] umdstu: has joined #RubyOnRails
[01:32:24] umdstu: Quit: umdstu
[20:21:57] umdstu: has joined #RubyOnRails
[20:31:55] umdstu: Quit: umdstu

2017-10-29

[19:49:26] umdstu: has joined #RubyOnRails
[19:50:36] umdstu: i’m using carrierwave to handle image uploads. in dev env, everything is working great, but in production, the filename in the _image_url path is a date rather than the original filename, wheras in dev the filename is the name of the file i upload
[19:51:25] umdstu: so instead of being /path/to/image/original_filename.png in development, it’s /path/to/image/todays_date-version.png in production
[22:24:47] umdstu: Quit: umdstu
[22:43:15] umdstu: has joined #RubyOnRails
[23:33:04] umdstu: Quit: umdstu

2017-06-13

[13:30:49] umdstu: has joined #ruby
[13:31:08] umdstu: is there a way to generate header files when building ruby from source on centos?
[13:51:06] umdstu: has joined #RubyOnRails
[13:51:54] umdstu: i'm trying to bundle install some gems but for some reason it's looking in the wrong location for the ruby.h file as opposed to (i assume non default) location of my .h file
[13:52:33] umdstu: is there a way to set an env variable to tell ruby where to look for headers?
[13:56:18] umdstu: yea give me a minute dminuoso
[13:59:56] umdstu: dminuoso: top of the output: https://gist.github.com/umdstu/102542eb8ad5650102575c331cd0fbf1
[14:01:10] umdstu: /srv/ruby-2.2.4/include/ruby/ruby.h
[14:01:40] umdstu: ruby --version yields ruby 2.2.4p230
[14:01:52] umdstu: yea idk why the admin put it there
[14:03:02] umdstu: no worries
[14:03:11] umdstu: i'm gonna tell him to properly install ruby :)
[14:05:25] umdstu: dminuoso: i thought that too. but i checked /usr/bin/ruby --version and it's 2.2.4p230
[14:05:40] umdstu: dminuoso: so he must have symlinked things instead
[14:08:09] umdstu: dminuoso: just chcked, there is a /usr/local/bin/ruby as well, --version yields same as above
[14:08:20] umdstu: so i can change PATH to look there first ig uess
[14:20:06] umdstu: dminuoso: umm
[14:20:12] umdstu: dminuoso: i'm not sure it's worth it
[14:20:32] umdstu: dminuoso: im leaning towards just symlinking the include dir that is good to the one it's looking for that doesn't exist
[14:20:37] umdstu: it's a test system
[14:22:02] umdstu: dminuoso: => "/usr/include/ruby-2.2.0"
[14:23:14] umdstu: dminuoso: awesome!
[14:23:34] umdstu: doesn't help yum repos are outdated and ruby has to be installed from source
[14:24:12] umdstu: dminuoso: yes
[14:24:39] umdstu: dminuoso: /usr/local/bin/ruby
[14:25:58] umdstu: dminuoso: yes 2.2.4p230
[14:26:25] umdstu: dminuoso: oh man
[14:26:28] umdstu: thats a lot of output
[14:26:39] umdstu: like i said, this is on a test sytem, i can't copy/paste it
[14:27:32] umdstu: topdir points to ruby-2.2.0
[14:27:51] umdstu: so does rubyhdrdir
[14:28:37] umdstu: it's a mess
[14:29:32] umdstu: /usr/bin/ruby
[14:52:48] umdstu: well i had him symlink the known good ruby/include/ dir that ruby couldn't see to the one it could. so now it sees it but... "checking for strlcpy() in string.h... *** extconf.rb failed ***
[14:53:06] umdstu: seems like I'm beat
[15:34:51] umdstu: dminuoso: => " '--enable-pthread' '--with-opt-dir=/usr' '--enable-shared'"
[15:35:48] umdstu: dminuoso: and => "2.2.4"
[15:35:54] umdstu: respectively
[15:39:15] umdstu: dminuoso: beginning to think it's just really jacked up and needs a reset
[17:18:41] umdstu: anyone installing rails on centos - is the recommended way to setup ruby by way of rbenv? or manu install from source
[17:26:03] umdstu: fryguy: yea i'm aware. i'm looking for best practices. historically we've had to compile ruby source, specifying libs and whatnot, and it's lead to inconsistent machines
[17:26:42] umdstu: fryguy: no
[17:26:57] umdstu: well that was my question
[19:47:27] umdstu: Remote host closed the connection

2017-05-16

[18:14:43] umdstu: Remote host closed the connection

2017-05-11

[11:32:45] umdstu: i have a RestClient request that works locally, but not in production. it fails with an sslv3 error. how do i determine the difference between the ruby installs and when openssl support each has

2017-05-10

[16:45:39] umdstu: has joined #ruby
[16:46:59] umdstu: i'm trying to connect to a host with RESTclient using TLSv1, but it keeps failing with: "...state=SSLv3 read finished A: sslv3 alert unexpected message>"
[16:47:20] umdstu: does that mean it's really not using TLS, or does it just use the same error messages

2017-05-01

[14:23:03] umdstu: has joined #RubyOnRails
[14:23:18] umdstu: trying to use capistrano to deploy an app to another server than my normal one. things go ok until it gets to precompiling the assets. I get this odd Encoding::ConverterNotFoundError: code converter not found (UTF-8 to UTF-32LE) error. it's the same branch, same ruby version
[14:25:36] umdstu: the stack trace points to this line: https://github.com/rails/sprockets/blob/v3.7.0/lib/sprockets/utils.rb#L106 but when i modify the file to print out Encoding::UTF_32LE, it finds it just fine. And if I try to manually encode that file in the console, it works fine
[14:25:51] umdstu: Andr3as: i'm on ruby-2.2, not jruby :/
[14:27:33] umdstu: no worries, i appreciate the help!
[17:46:00] umdstu: Remote host closed the connection

2017-04-26

[19:33:19] umdstu: Remote host closed the connection

2017-04-21

[14:31:15] umdstu: has joined #ruby
[14:32:43] umdstu: trying to use capistrano to deploy an app to another server than my normal one. things go ok until it gets to precompiling the assets. I get this odd Encoding::ConverterNotFoundError: code converter not found (UTF-8 to UTF-32LE) error. it's the same branch

2017-03-29

[19:02:40] umdstu: Remote host closed the connection

2017-03-28

[19:19:00] umdstu: has joined #RubyOnRails
[19:19:38] umdstu: i some global variables declared in an initializer class. they seem to be accessible no problem from controllers, but my custom classes can't see them

2017-03-21

[20:04:49] umdstu: Remote host closed the connection

2017-03-20

[12:04:07] umdstu: has joined #ruby
[12:04:20] umdstu: how would I convert a datetime value to a 64bit unsigned integer
[15:37:49] umdstu: i tried to add some custom Exceptions to my app, wrapped them in module Exceptions and put them in lib dir for the app. the lib dir is added to autoload list but the new exception classes aren't being detected in the controller

2017-03-17

[16:55:07] umdstu: has joined #RubyOnRails
[16:55:30] umdstu: is it possible to call a java jar with option to get a result back from in my rails app
[16:58:12] umdstu: centrx: i tried that but i dont get anything back or errors

2017-03-16

[18:41:05] umdstu: has joined #ruby
[18:41:12] umdstu: is there a best practice for communicating with a java jar daemon from inside ruby?
[19:54:24] umdstu: ty hxegon i will look into that
[19:55:01] umdstu: hxegon: ahh.. yea i'm not using jruby
[20:06:06] umdstu: Remote host closed the connection

2017-03-10

[16:49:37] umdstu: i'm getting an uninitialized constant error for a class I have in /lib/ (path has been added to autoload path). I'm using the class inside another class
[16:51:02] umdstu: matthewd: config.autoload_paths += %w(#{Rails.root}/lib) in application.rb
[16:51:46] umdstu: if i use the ClassName.function I get uninitialized constant ParentClassName::ClassName. if i use the ::ClassName.function I get uninitialized constant ClassName
[16:52:22] umdstu: matthewd: filename is class_name.rb, classname is ClassName, they match though
[16:53:01] umdstu: matthewd: rails 5, dev env
[16:53:18] umdstu: dminuoso: No
[16:54:07] umdstu: no. but i should also note, that class_name.rb has two classes in it, not nested
[16:54:42] umdstu: matthewd: correct
[16:55:46] umdstu: matthewd: re: your previous question, eager_load is false in dev, but nothing about autoloading
[16:59:09] umdstu: matthewd: had to check. yes it works if i require it above the class i'm using it in
[17:01:59] umdstu: I have restarted multiple times. the file is new though
[17:02:18] umdstu: let me check if when i restart, it's actually restarting puma
[17:02:56] umdstu: matthewd: no it's been in there. i have other classes in there
[17:03:51] umdstu: do i need to make it a module instead of a class ?
[17:05:03] umdstu: add an error, but remove the require?
[17:06:36] umdstu: how can i tell if it loaded
[17:07:35] umdstu: starting the server should fail? yea it chugged along.
[17:07:48] umdstu: i had tossed the letter s on a line
[17:13:06] umdstu: matthewd: that worked
[17:15:59] umdstu: matthewd: yea it's wonky
[17:16:12] umdstu: whatever. i'll deal with it later if i remember. just need to have it work for now :)

2017-03-08

[17:02:20] umdstu: has joined #RubyOnRails
[17:02:49] umdstu: i just deployed a rails app to a new server. i got this weird error from sprockets: code converter not found (UTF-8 to UTF-32LE)

2016-07-29

[11:49:09] umdstu: has joined #RubyOnRails
[11:49:09] umdstu: has joined #ruby
[18:45:38] umdstu: Quit: umdstu

2016-07-28

[19:13:43] umdstu: Quit: umdstu

2016-07-27

[11:26:38] umdstu: has joined #RubyOnRails
[11:26:38] umdstu: has joined #ruby

2016-07-26

[19:04:19] umdstu: Quit: umdstu

2016-07-25

[11:43:42] umdstu: has joined #RubyOnRails
[11:43:42] umdstu: has joined #ruby

2016-07-22

[06:56:35] umdstu: Read error: Connection reset by peer
[06:57:23] umdstu: has joined #RubyOnRails
[06:57:23] umdstu: has joined #ruby
[19:20:33] umdstu: Quit: umdstu

2016-07-21

[12:23:31] umdstu: has joined #RubyOnRails
[12:23:31] umdstu: has joined #ruby

2016-07-20

[20:22:35] umdstu: Quit: umdstu

2016-07-19

[11:56:18] umdstu: has joined #RubyOnRails
[11:56:18] umdstu: has joined #ruby

2016-07-18

[12:00:05] umdstu: has joined #RubyOnRails
[12:00:05] umdstu: has joined #ruby
[18:28:18] umdstu: Quit: umdstu

2016-07-15

[12:19:00] umdstu: has joined #ruby
[12:19:01] umdstu: has joined #RubyOnRails
[19:40:04] umdstu: Quit: umdstu

2016-07-14

[12:54:37] umdstu: has joined #ruby
[12:54:38] umdstu: has joined #RubyOnRails
[17:59:19] umdstu: i recently updated to rest-client 2.0 and response.cookies isn’t being populated by the cookie field in the response headers for some reason. anyone run across this?
[18:48:41] umdstu: Quit: umdstu

2016-07-13

[12:06:39] umdstu: has joined #RubyOnRails
[12:06:39] umdstu: has joined #ruby
[17:57:47] umdstu: Quit: umdstu

2016-07-12

[16:41:55] umdstu: Ping timeout: 252 seconds
[16:47:28] umdstu: has joined #RubyOnRails
[16:47:28] umdstu: has joined #ruby
[19:03:24] umdstu: Quit: umdstu

2016-07-11

[11:01:24] umdstu: has joined #RubyOnRails
[11:01:24] umdstu: has joined #ruby

2016-07-08

[11:02:30] umdstu: has joined #RubyOnRails
[11:02:30] umdstu: has joined #ruby
[11:07:48] umdstu: trying to parse some data from resp, and after cleaning it up, and i trying to render it back as json in a response, I get “Encoding::UndefinedConversionError (“\xD9” from ASCII-8BIT to UTF-8):; even after i called to_s.encode(‘UTF-9’, {invalid: :replace, undef: :replace, replace: ‘?’}) on the values being cleaned up.
[11:17:48] umdstu: well i just drank a red bull, so....
[11:22:33] umdstu: sugar free, of course. gotta keep this hot bod.
[19:54:22] umdstu: Quit: umdstu

2016-07-07

[11:07:39] umdstu: has joined #RubyOnRails
[18:43:30] umdstu: has joined #ruby
[18:45:55] umdstu: trying to parse some data from a mongodb store, and after cleaning it up, and i trying to render it as json in a response, I get “Encoding::UndefinedConversionError (“\xD9” from ASCII-8BIT to UTF-8):; even after i called to_s.encode(‘UTF-9’) on the values being cleaned up.
[18:50:26] umdstu: Quit: umdstu

2016-07-06

[12:42:30] umdstu: has joined #RubyOnRails
[20:07:52] umdstu: Quit: umdstu

2016-07-05

[12:09:37] umdstu: has joined #RubyOnRails
[20:16:14] umdstu: Quit: umdstu

2016-06-30

[20:00:44] umdstu: Quit: umdstu

2016-06-29

[10:28:35] umdstu: has joined #RubyOnRails
[12:18:03] umdstu: where would be the appropriate location to call a method on each result in a relation? i need to potentially filter out some of the records
[12:18:39] umdstu: instead of calling .each on the set and putting ones that the method OKs into a new array
[12:34:03] umdstu: how would i call a method on each of these searches before passing off to view? `searches = current_user.image_groups.order(‘name asc’).to_json(include: { image: {only: [:name, :id]}}, methods: not_deleted)`
[12:34:13] umdstu: or rather, where
[12:47:21] umdstu: the json isn’t being used in rails though, being sent to an angular UI
[12:47:28] umdstu: dminuoso:
[13:08:24] umdstu: dminuoso: then i misunderstood what you meant by decorators
[13:08:32] umdstu: time for some internetting
[13:10:30] umdstu: right, that sounds overkill. thanks for the tip

2016-06-28

[12:40:09] umdstu: has joined #RubyOnRails
[19:44:08] umdstu: Quit: umdstu

2016-06-27

[10:43:02] umdstu: has joined #RubyOnRails
[19:02:09] umdstu: Quit: umdstu

2016-06-24

[11:20:44] umdstu: has joined #RubyOnRails
[15:50:40] umdstu: Quit: umdstu

2016-06-23

[13:28:20] umdstu: has joined #RubyOnRails
[21:00:31] umdstu: Quit: umdstu

2016-06-22

[10:42:47] umdstu: has joined #RubyOnRails
[17:38:45] umdstu: Quit: umdstu

2016-06-21

[11:13:19] umdstu: has joined #RubyOnRails
[11:13:23] umdstu: has left #RubyOnRails: ()
[11:15:59] umdstu: has joined #RubyOnRails
[11:16:50] umdstu: i’m getting a method undefined method `each’ for nil:NilClass when inspecting an object. can’t seem to make sense of it
[11:18:53] umdstu: that’s the problem. i’m not calling it on nil.
[11:19:57] umdstu: alright try to explain again, and if i’m still wrong, i’ll break it
[11:21:39] umdstu: i have an object, `#<Result fields=[{…..>` . puts object.class yields `Result`. puts object.inspect prints object. puts object.fields yields nil error
[11:22:03] umdstu: sure i’ll try to retype it
[11:22:26] umdstu: go ahead and make fun
[11:22:30] umdstu: code is on different network
[11:22:34] umdstu: literally cannot copy or past
[11:25:04] umdstu: so… even if i dont try to output the object, if i simply call `if fields` in the model class, it throws that nil error
[11:25:32] umdstu: sure give me another moment to type something up
[11:27:29] umdstu: folks, i realize that
[11:27:44] umdstu: but 100% context cannot be obtained unfrotunately since I can’t type all the code
[11:27:50] umdstu: or rather, paste it
[11:28:14] umdstu: Dysp: it’s on another network
[11:28:21] umdstu: i said this
[11:28:43] umdstu: i’m on that network
[11:28:49] umdstu: that network != this network
[11:29:28] umdstu: wethu: no, i just said i’m on that network
[11:29:56] umdstu: i’d rather keep my job :)
[11:30:14] umdstu: so, i’m not actually to the point in which .each is called… by me
[11:30:29] umdstu: i simply have ‘if fields’ and it calls the .each nil class error
[11:30:42] umdstu: s/calls/throws/
[11:32:50] umdstu: here’s the object… `#<Result fields=[{…..>` … `if fields` throws undefined method each for nil. fields is clearly there. its an array
[11:33:07] umdstu: Result is a recursiveopenstruct
[11:33:15] umdstu: sevenseacat: i’m in result.rb
[11:33:34] umdstu: so it does, no?
[11:34:08] umdstu: i think my circumstances are making it more difficult. i’m trying my best. i’m open to suggestions though :)
[11:36:39] umdstu: mikecmpbll: ^
[11:36:44] umdstu: here’s a snippet
[11:36:45] umdstu: https://gist.github.com/umdstu/7b9453bf0b8d1242ac74ca26198cfa7b
[11:36:57] umdstu: yes its not connected to the intertubes
[11:37:40] umdstu: http://www.rubydoc.info/github/opower/clean_config/RecursiveOpenStruct sevenseacat
[11:39:10] umdstu: NoMethodError (undefined method `each’ for nil:NilClass): app/models/result_event_helper.rb:5
[11:40:06] umdstu: thats the confusing part… it must be something inside RecursiveOpenStruct
[11:42:09] umdstu: https://rubygems.org/gems/recursive-open-struct/versions/1.0.1 a better link?
[11:43:16] umdstu: i just updated the gist to where i put the log statement. that log statement, as i mentioned earlier, is…. `#<Result fields=[{“Value”…}]`
[11:43:31] umdstu: so fields is there
[11:43:37] umdstu: and its an array
[11:44:27] umdstu: if i log fields, i get the each nil error
[11:47:08] umdstu: mikecmpbll: sevenseacat thanks for trying
[12:31:00] umdstu: wethu: yes, as you no doubt know, this why typing gist code is bad. :/
[18:59:15] umdstu: Quit: umdstu

2016-05-24

[19:44:07] umdstu: Quit: umdstu